$re = '/(^\s*(([<>=][=]{0,1})|(<>))\s*\d+(\.\d+)?$)|^\s*$/';
$str = '12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);