import Foundation
let pattern = #"<slb:ReturnCode>([^<]*?)<\/slb:ReturnCode>[\s\S]*?<slb:Message>([^<]*?)<\/slb:Message>[\s\S]*?<slb:Message>([^<]*?)<\/slb:Message>[\s\S]*?<slb:Count>([^<]*?)<\/slb:Count>|<slb:SerialNumber>([^<]*?)<\/slb:SerialNumber>[\s\S]*?<slb:Type>([^<]*?)<\/slb:Type>[\s\S]*?<slb:Outlet>([^<]*?)<\/slb:Outlet>[\s\S]*?<slb:Status>([^<]*?)<\/slb:Status>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"<?xml version="1.0" encoding="utf-8"?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:slb="http://www.csgsystems.com/slbos"><soapenv:Header /><soapenv:Body><slb:ExchangeCustomerLocationEquipmentResponse><slb:head><slb:Client>ElnkFive9IOT</slb:Client><slb:RoutingArea>8024</slb:RoutingArea><slb:Region>QAHA</slb:Region><slb:Source>IVR</slb:Source><slb:Destination>CCS</slb:Destination><slb:Version>2.26</slb:Version><slb:Operator>IVR</slb:Operator><slb:TransactionId>4406606e-1563-11eb-8111-005056b21df3</slb:TransactionId><slb:ServerId>OTPRESLBWCF04</slb:ServerId></slb:head><slb:Response><slb:ReturnCode>0000</slb:ReturnCode><slb:Message>ISP23I EXTRA EQPT/COMPONENTS DISABLED</slb:Message><slb:Message>A950527CE7C60H5 -COLLECTION NEVER ATTEMPTED</slb:Message></slb:Response><slb:Business><slb:BusinessUnit>802440000360</slb:BusinessUnit></slb:Business><slb:Customer><slb:CustomerId>1101521209580</slb:CustomerId></slb:Customer><slb:Location><slb:LocationId>11322010200009</slb:LocationId></slb:Location><slb:EquipmentList><slb:ReturnStatus>R</slb:ReturnStatus><slb:ReturnLocation>0000000000000001</slb:ReturnLocation><slb:Count>3</slb:Count><slb:ReturnedCount>3</slb:ReturnedCount><slb:Equipment><slb:SerialNumber>C8C937E6B65C </slb:SerialNumber><slb:HandshakeId>#0010</slb:HandshakeId><slb:Type>MN</slb:Type><slb:TypeDescription>D3 Modem-Arris</slb:TypeDescription><slb:SubType> </slb:SubType><slb:Outlet>A </slb:Outlet><slb:Sequence>00</slb:Sequence><slb:Status>H</slb:Status><slb:StatusDescription>Active</slb:StatusDescription><slb:CurrentLocation>8024400360071309</slb:CurrentLocation><slb:CurrentLocationEntryDate>2020-10-22</slb:CurrentLocationEntryDate><slb:Manufacturer>AR</slb:Manufacturer><slb:Make>ARRIS</slb:Make><slb:Model>DG3270 </slb:Model><slb:ModelDescription>Arris Modem</slb:ModelDescription><slb:Ownership>P</slb:Ownership><slb:OwnershipDescription>PURCHASED </slb:OwnershipDescription><slb:Inventoried>I</slb:Inventoried><slb:SignalType>D</slb:SignalType><slb:ComponentCount>1</slb:ComponentCount><slb:Component><slb:Code>03</slb:Code><slb:CodeDescription> </slb:CodeDescription><slb:Status>H</slb:Status><slb:StatusDescription>Active</slb:StatusDescription><slb:Path>27</slb:Path><slb:Category>03</slb:Category><slb:AddressingMode>1</slb:AddressingMode><slb:Usage><slb:Enabled>Y</slb:Enabled></slb:Usage><slb:ItemCount>4</slb:ItemCount><slb:Item><slb:ServiceIdentifier>000011</slb:ServiceIdentifier><slb:ParentServiceIdentifier>000011</slb:ParentServiceIdentifier><slb:Code>F0090</slb:Code><slb:CodeDescription>EDGEW 100 </slb:CodeDescription><slb:LineOfBusiness><slb:Type>I</slb:Type></slb:LineOfBusiness></slb:Item><slb:Item><slb:ServiceIdentifier>000005</slb:ServiceIdentifier><slb:ParentServiceIdentifier>000005</slb:ParentServiceIdentifier><slb:Code>F0089</slb:Code><slb:CodeDescription>INTERNETBASE</slb:CodeDescription><slb:LineOfBusiness><slb:Type>I</slb:Type></slb:LineOfBusiness></slb:Item><slb:Item><slb:ServiceIdentifier>000010</slb:ServiceIdentifier><slb:ParentServiceIdentifier>000010</slb:ParentServiceIdentifier><slb:Code>O$</slb:Code><slb:CodeDescription>D3 MODEM </slb:CodeDescription><slb:LineOfBusiness><slb:Type>I</slb:Type></slb:LineOfBusiness></slb:Item><slb:Item><slb:ServiceIdentifier>000007</slb:ServiceIdentifier><slb:ParentServiceIdentifier>000007</slb:ParentServiceIdentifier><slb:Code>A0014</slb:Code><slb:CodeDescription>INELIGTOCNCL</slb:CodeDescription><slb:LineOfBusiness><slb:Type>N</slb:Type></slb:LineOfBusiness></slb:Item></slb:Component><slb:ReceiptDate>2018-06-28</slb:ReceiptDate><slb:RepairDate>0001-01-01</slb:RepairDate><slb:ShipDate>2018-06-28</slb:ShipDate><slb:VendorDescription>ARRIS </slb:VendorDescription><slb:VendorModel>DG3270 </slb:VendorModel><slb:DOCSISVersion>0</slb:DOCSISVersion><slb:RecordState>CHG</slb:RecordState></slb:Equipment><slb:Equipment><slb:SerialNumber>A950527CE7C60H5 </slb:SerialNumber><slb:HandshakeId>#0020</slb:HandshakeId><slb:Type>TV</slb:Type><slb:TypeDescription>Tivo Mi4</slb:TypeDescription><slb:SubType> </slb:SubType><slb:Outlet>B </slb:Outlet><slb:Sequence>00</slb:Sequence><slb:Status>H</slb:Status><slb:StatusDescription>Active</slb:StatusDescription><slb:CurrentLocation>8024400360071309</slb:CurrentLocation><slb:CurrentLocationEntryDate>2020-10-22</slb:CurrentLocationEntryDate><slb:Make>TIVO </slb:Make><slb:Model>MI4 </slb:Model><slb:Ownership>P</slb:Ownership><slb:OwnershipDescription>PURCHASED </slb:OwnershipDescription><slb:Inventoried>I</slb:Inventoried><slb:SignalType>A</slb:SignalType><slb:ComponentCount>1</slb:ComponentCount><slb:Component><slb:Code>01</slb:Code><slb:CodeDescription> </slb:CodeDescription><slb:Status>H</slb:Status><slb:StatusDescription>Active</slb:StatusDescription><slb:Path>27</slb:Path><slb:Category>01</slb:Category><slb:AddressingMode>0</slb:AddressingMode><slb:Usage><slb:Enabled>Y</slb:Enabled></slb:Usage><slb:ItemCount>4</slb:ItemCount><slb:Item><slb:ServiceIdentifier>000012</slb:ServiceIdentifier><slb:ParentServiceIdentifier>000012</slb:ParentServiceIdentifier><slb:Code>OL002</slb:Code><slb:CodeDescription>DVR </slb:CodeDescription><slb:LineOfBusiness><slb:Type>C</slb:Type></slb:LineOfBusiness></slb:Item><slb:Item><slb:ServiceIdentifier>000004</slb:ServiceIdentifier><slb:ParentServiceIdentifier>000004</slb:ParentServiceIdentifier><slb:Code>BL051</slb:Code><slb:CodeDescription>TV CH EXCH </slb:CodeDescription><slb:LineOfBusiness><slb:Type>C</slb:Type></slb:LineOfBusiness></slb:Item><slb:Item><slb:ServiceIdentifier>000006</slb:ServiceIdentifier><slb:ParentServiceIdentifier>000006</slb:ParentServiceIdentifier><slb:Code>OL092</slb:Code><slb:CodeDescription>ESSEN+ BASE </slb:CodeDescription><slb:LineOfBusiness><slb:Type>C</slb:Type></slb:LineOfBusiness></slb:Item><slb:Item><slb:ServiceIdentifier>000007</slb:ServiceIdentifier><slb:ParentServiceIdentifier>000007</slb:ParentServiceIdentifier><slb:Code>A0014</slb:Code><slb:CodeDescription>INELIGTOCNCL</slb:CodeDescription><slb:LineOfBusiness><slb:Type>N</slb:Type></slb:LineOfBusiness></slb:Item></slb:Component><slb:ReceiptDate>2020-06-10</slb:ReceiptDate><slb:RepairDate>0001-01-01</slb:RepairDate><slb:ShipDate>2020-06-10</slb:ShipDate><slb:OffPremiseEquipment><slb:UnitNumber>TION NEVER AT</slb:UnitNumber><slb:Port><slb:Number> </slb:Number></slb:Port></slb:OffPremiseEquipment><slb:RecordState>NOC</slb:RecordState></slb:Equipment><slb:Equipment><slb:SerialNumber>DBD1BDA5C3DA </slb:SerialNumber><slb:HandshakeId>#0030</slb:HandshakeId><slb:Type>MN</slb:Type><slb:TypeDescription>D3 Modem-Arris</slb:TypeDescription><slb:SubType> </slb:SubType><slb:Outlet>C </slb:Outlet><slb:Sequence>00</slb:Sequence><slb:Status>D</slb:Status><slb:StatusDescription>Disabled</slb:StatusDescription><slb:CurrentLocation>8024400360071309</slb:CurrentLocation><slb:CurrentLocationEntryDate>2020-10-22</slb:CurrentLocationEntryDate><slb:Manufacturer>AR</slb:Manufacturer><slb:Make>MOTLA</slb:Make><slb:Model>DG3270 </slb:Model><slb:ModelDescription>Arris Modem</slb:ModelDescription><slb:Ownership>R</slb:Ownership><slb:OwnershipDescription>RENTAL/LEASE </slb:OwnershipDescription><slb:Inventoried>I</slb:Inventoried><slb:SignalType>D</slb:SignalType><slb:ComponentCount>1</slb:ComponentCount><slb:Component><slb:Code>03</slb:Code><slb:CodeDescription> </slb:CodeDescription><slb:Status>D</slb:Status><slb:StatusDescription>Disabled</slb:StatusDescription><slb:Path>27</slb:Path><slb:Category>03</slb:Category><slb:AddressingMode>1</slb:AddressingMode><slb:Usage><slb:Enabled>Y</slb:Enabled></slb:Usage><slb:ItemCount>0</slb:ItemCount></slb:Component><slb:ReceiptDate>2018-04-02</slb:ReceiptDate><slb:RepairDate>0001-01-01</slb:RepairDate><slb:ShipDate>2018-04-02</slb:ShipDate><slb:VendorDescription>ARRIS </slb:VendorDescription><slb:VendorModel>DG3270 </slb:VendorModel><slb:DOCSISVersion>0</slb:DOCSISVersion><slb:RecordState>CHG</slb:RecordState></slb:Equipment></slb:EquipmentList></slb:ExchangeCustomerLocationEquipmentResponse></soapenv:Body></soapenv:Envelope>"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)