import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d*#\\D)|(\\d*#^)";
final String string = "\"8617722824323#312|86259920#None17722825198#\"\n"
+ "1777213134#|+8617722824323#\n"
+ "8617722824323#312\n"
+ "1777213134#\n"
+ "8617722824323#312";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}