package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\<\*?\d+`)
var str = `abc<*15<<def<*3ghi
jkl<42<<mno<7pqrst`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}