package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.+\/\/|www.|\..+`)
var str = `http://google.com
http://google.co.jp`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}