$re = '/\(?(\d+\.?\d*)\)?\^\(?(\d+\.?\d*)\)?/m';
$str = '(124+3323322/23323)^(132323)+12345^4321134';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);