$re = '/^(?=.{18}$)(?!198.)([0-9]{4})(.*?)\1/m';
$str = '1976UnoDosTres1976';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);