import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*Device:\\s*(.*?)\\s*Serial Number.*)|(.*Gerät:\\s*(.*?)\\s*Seriennummer.*)|(.*ICD-Model:\\s*(.*?)\\s*Serial Number:.*)|(.*ICD-Modell:\\s*(.*?)\\s*Seriennummer.*)|(.*Pacemaker Model:\\s*(.*?)\\s*Serial Number.*)|(.*Schrittmachermodell:\\s*(.*?)\\s*Seriennummer:.*)";
final String string = "Device:REVEAL LINQ LNQ11 Serial Number:RLA087267G Date of Visit:03-Jul-2019 08:10:51 \n"
+ "Gerät:Viva Quad XT CRT-D DTBA2QQ Seriennummer:BLG613658S Untersuchungsdatum:27-Apr-2018 12:34:06 \n"
+ "ICD-Modell: Marquis VR 7230 Seriennummer: PKD616419S Untersuchungsdatum:12, Mai 2015 \n"
+ "ICD-Model: Marquis VR 7230 Serial Number: PKD616419S Untersuchungsdatum:12, Mai 2015 \n"
+ "Pacemaker Model: Medtronic Adapta ADSR01 Serial Number: NWM851790 Date of Visit: 12/08/17 \n"
+ "Schrittmachermodell: Medtronic Adapta ADVDD01 Seriennummer: NWG618042 Nachsorgedatum: 05.12.1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}