const regex = /\{([^\{\}]|(?R))*\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{([^\\{\\}]|(?R))*\\}', 'g')
const str = `Wind energy is the kinetic energy of air in motion, also called wind. Total wind energy flowing through an imaginary surface with area A during the time t is:
{\\displaystyle E={\\frac {1}{2}}mv^{2}={\\frac {1}{2}}(Avt\\rho )v^{2}={\\frac {1}{2}}At\\rho v^{3},} E={\\frac {1}{2}}mv^{2}={\\frac {1}{2}}(Avt\\rho )v^{2}={\\frac {1}{2}}At\\rho v^{3},[248]
where ρ is the density of air; v is the wind speed; Avt is the volume of air passing through A (which is considered perpendicular to the direction of the wind); Avtρ is therefore the mass m passing through "A". Note that ½ ρv2 is the kinetic energy of the moving air per unit volume.
Power is energy per unit time, so the wind power incident on A (e.g. equal to the rotor area of a wind turbine) is:
{\\displaystyle P={\\frac {E}{t}}={\\frac {1}{2}}A\\rho v^{3}.} P={\\frac {E}{t}}={\\frac {1}{2}}A\\rho v^{3}.[248]
Wind power in an open air stream is thus proportional to the third power of the wind speed; the available power increases eightfold when the wind speed doubles. Wind turbines for grid electric power therefore need to be especially efficient at greater wind speeds.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}