# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^我?(想|要)?(到|去)?#都?有?((哪(儿|里)?|(啥|什么|哪些|啥子))((好|可)玩儿?的?(地(方|儿)?)?|好?地(方|儿))去?|(怎么|咋)玩儿?|(什么|啥|哪些)好?((旅游|游玩)?(景点|攻略)|风景区|旅游区))(吗|呢|不|吧|嘛|么|呀|没|啊|阿)?$"
test_str = ("\n"
"#怎么玩\n"
"#有哪里好玩的\n"
"#有哪里好玩\n"
"#什么好玩的\n"
"#哪儿好玩\n"
"#什么好玩的地方\n"
"#有什么好玩的\n"
"#有哪好玩的\n"
"#都有什么好玩的\n"
"#有什么好地方\n"
"#啥好玩的\n"
"#有什么可玩的\n"
"#有什么好玩的地\n"
"#有啥可玩的\n"
"#有哪好玩\n"
"#什么景点\n"
"#有什么好玩的呀\n"
"#有什么好玩\n"
"#有哪些好玩的\n"
"#有哪里好玩的地方\n"
"#有啥好玩的没\n"
"#都有哪些好玩的\n"
"#有什么风景区\n"
"#有什么好景点\n"
"#有什么好玩的阿\n"
"#有哪里好玩呀\n"
"#有什么好玩的地儿\n"
"#有什么地方去\n"
"#有什么好玩的没\n"
"#有啥好玩的不\n"
"#哪儿好玩儿\n"
"#有什么可玩儿的\n"
"#哪儿好玩呀\n"
"#有啥好玩的地方\n"
"#什么好玩的呀\n"
"#有什么好玩的地方\n"
"#有啥子好玩的\n"
"#什么好玩儿的\n"
"#都有什么景点\n"
"去#有什么好玩的地方\n"
"我想去#有什么好玩儿的\n"
"去#有什么好玩的呀\n"
"去#有什么好玩\n\n\n"
"去#旅游怎么样\n"
"去#玩什么\n"
"去#玩\n"
"去#玩怎么样\n"
"#去哪里好玩\n"
"#有什么玩的\n"
"#有好玩的么\n"
"#什么地方好玩\n"
"#攻略有吗\n"
"#好玩的地方有哪些\n\n"
"去#的攻略\n"
"#风景区\n"
"去#旅游\n"
"#周边游\n"
"#游玩攻略\n\n\n"
"#有什么可玩的\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.