const regex = /^([A-Z]|[a-z]|\s)+(,\s*(Jr\.|Sr\.|[IV]*))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Z]|[a-z]|\\s)+(,\\s*(Jr\\.|Sr\\.|[IV]*))?$', 'gm')
const str = ` John Smith, Jr.
Winn Thomas
Mary 3llen Jones
Clyde Franklin, III
wallace firt, the
wimbobimbo ff , VIVIVVVVIIIVIIVVI
s f asdf s dfFASFSf dsf saf sFD s faS fdy t sg , Sr.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}