$re = '/\P{Cc}/m';
$str = 'characters such as can enter the system';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);