#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\x1B(?:[@-Z\\-_]|\[[0-?]*[ -/]*[@-~])"
Local $sString = "[1;34md[33mr[31mw[32mx[0m[33mr[31mw[32mx[33mr[38;5;244m-[32mx[0m [38;5;244m-[0m [1;33msebi[0m [1;33msebi[0m [34m 1 Jun 09:08[0m [1;34m.git[0m" & @CRLF & _
"[1;34md[33mr[31mw[32mx[0m[33mr[31mw[32mx[33mr[38;5;244m-[32mx[0m [38;5;244m-[0m [1;33msebi[0m [1;33msebi[0m [34m 6 Apr 11:13[0m [1;34m.github[0m" & @CRLF & _
".[1;33mr[31mw[0m[38;5;244m-[33mr[31mw[38;5;244m-[33mr[38;5;244m--[0m [1;32m993[0m [1;33msebi[0m [1;33msebi[0m [34m 6 Apr 11:13[0m .gitignore" & @CRLF & _
"[1;34md[33mr[31mw[32mx[0m[33mr[31mw[32mx[33mr[38;5;244m-[32mx[0m [38;5;244m-[0m [1;33msebi[0m [1;33msebi[0m [34m21 Apr 14:54[0m [1;34m.pytest_cache[0m" & @CRLF & _
"[1;34md[33mr[31mw[32mx[0m[33mr[31mw[32mx[33mr[38;5;244m-[32mx[0m [38;5;244m-[0m [1;33msebi[0m [1;33msebi[0m [34m 7 Apr 17:34[0m [1;34m.tox[0m" & @CRLF & _
"[1;34md[33mr[31mw[32mx[0m[33mr[31mw[32mx[33mr[38;5;244m-[32mx[0m [38;5;244m-[0m [1;33msebi[0m [1;33msebi[0m [34m21 Apr 14:24[0m [1;34m.venv[0m" & @CRLF & _
".[1;33mr[31mw[0m[38;5;244m-[33mr[31mw[38;5;244m-[33mr[38;5;244m--[0m [1;32m1,0[0m[32mk[0m [1;33msebi[0m [1;33msebi[0m [34m 6 Apr 11:13[0m CITATION.cff" & @CRLF & _
"[1;34md[33mr[31mw[32mx[0m[33mr[31mw[32mx[33mr[38;5;244m-[32mx[0m [38;5;244m-[0m [1;33msebi[0m [1;33msebi[0m [34m 6 Apr 11:13[0m [1;34mconfig[0m" & @CRLF & _
"[1;34md[33mr[31mw[32mx[0m[33mr[31mw[32mx[33mr[38;5;244m-[32mx[0m [38;5;244m-[0m [1;33msebi[0m [1;33msebi[0m [34m 6 Apr 11:13[0m [1;34mdocs[0m" & @CRLF & _
".[1;33mr[31mw[0m[38;5;244m-[33mr[31mw[38;5;244m-[33mr[38;5;244m--[0m [1;32m35[0m[32mk[0m [1;33msebi[0m [1;33msebi[0m [34m 6 Apr 11:13[0m LICENSE" & @CRLF & _
"[1;34md[33mr[31mw[32mx[0m[33mr[31mw[32mx[33mr[38;5;244m-[32mx[0m [38;5;244m-[0m [1;33msebi[0m [1;33msebi[0m [34m 6 Apr 11:13[0m [1;34mprovisioning[0m" & @CRLF & _
".[1;33mr[31mw[0m[38;5;244m-[33mr[31mw[38;5;244m-[33mr[38;5;244m--[0m [1;32m9,1[0m[32mk[0m [1;33msebi[0m [1;33msebi[0m [34m 6 Apr 11:13[0m [1;4;33mREADME.md[0m" & @CRLF & _
".[1;33mr[31mw[0m[38;5;244m-[33mr[31mw[38;5;244m-[33mr[38;5;244m--[0m [1;32m133[0m [1;33msebi[0m [1;33msebi[0m [34m 6 Apr 11:13[0m requirements.txt" & @CRLF & _
".[1;33mr[31mw[4;32mx[0m[33mr[31mw[32mx[33mr[38;5;244m-[32mx[0m [1;32m443[0m [1;33msebi[0m [1;33msebi[0m [34m 6 Apr 11:13[0m [32mrun_sample_simulation[0m" & @CRLF & _
".[1;33mr[31mw[0m[38;5;244m-[33mr[31mw[38;5;244m-[33mr[38;5;244m--[0m [1;32m1,3[0m[32mk[0m [1;33msebi[0m [1;33msebi[0m [34m 6 Apr 11:13[0m setup.py" & @CRLF & _
"[1;34md[33mr[31mw[32mx[0m[33mr[31mw[32mx[33mr[38;5;244m-[32mx[0m [38;5;244m-[0m [1;33msebi[0m [1;33msebi[0m [34m 6 Apr 11:14[0m [1;34msrc[0m" & @CRLF & _
"[1;34md[33mr[31mw[32mx[0m[33mr[31mw[32mx[33mr[38;5;244m-[32mx[0m [38;5;244m-[0m [1;33msebi[0m [1;33msebi[0m [34m 6 Apr 11:13[0m [1;34mtools[0m" & @CRLF & _
".[1;33mr[31mw[0m[38;5;244m-[33mr[31mw[38;5;244m-[33mr[38;5;244m--[0m [1;32m526[0m [1;33msebi[0m [1;33msebi[0m [34m 6 Apr 11:13[0m tox.ini" & @CRLF & _
".[1;33mr[31mw[0m[38;5;244m-[33mr[31mw[38;5;244m-[33mr[38;5;244m--[0m [1;32m1,4[0m[32mk[0m [1;33msebi[0m [1;33msebi[0m [34m19 Mai 09:54[0m windows_iso_and_openssh_update.path" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)