#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^1?$|^(11+?)\1+$"
Local $sString = "" & @CRLF & _
"1" & @CRLF & _
"11" & @CRLF & _
"111" & @CRLF & _
"1111" & @CRLF & _
"11111" & @CRLF & _
"111111" & @CRLF & _
"1111111" & @CRLF & _
"11111111" & @CRLF & _
"111111111" & @CRLF & _
"1111111111" & @CRLF & _
"11111111111" & @CRLF & _
"111111111111" & @CRLF & _
"1111111111111" & @CRLF & _
"11111111111111" & @CRLF & _
"111111111111111" & @CRLF & _
"1111111111111111" & @CRLF & _
"11111111111111111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")