// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(0[1-9]|[12]\d|3[01])\/(0[1-9]|1[0-2])\/\d{4}$").unwrap();
let string = "13/12/2024";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}