const regex = new RegExp('<hi>((.|\\n)*?)</hi>', 'gm')
const str = `<hi>
Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. Aenean tincidunt diam sit amet semper vestibulum. Donec dictum dapibus magna vitae pharetra. Fusce condimentum velit at tempus aliquam. Maecenas maximus scelerisque nisi, et gravida felis molestie quis. Nunc nec mauris in ligula imperdiet rhoncus. Donec dignissim magna eu consectetur luctus.
Phasellus sed massa vitae nisl congue congue. Etiam nec luctus dolor, eget placerat ligula. Fusce mollis neque vitae fermentum gravida. Suspendisse maximus felis risus, vel fringilla mauris tristique quis. Orci varius natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Orci varius natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Interdum et malesuada fames ac ante ipsum primis in faucibum
</hi>
Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. Aenean tincidunt diam sit amet semper vestibulum. Donec dictum dapibus magna vitae pharetra. Fusce condimentum velit at tempus aliquam. Maecenas maximus scelerisque nisi, et gravida felis molestie quis. Nunc nec mauris in ligula imperdiet rhoncus. Donec dignissim magna eu consectetur luctus. Phasellus sed massa vitae nisl congue congue. Etiam nec luctus dolor, eget placerat ligula. Fusce mollis neque vitae fermentum gravida. Suspendisse maximus felis risus, vel fringilla mauris tristique quis. Orci varius natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Orci varius natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Interdum et malesuada fames ac ante ipsum primis in faucibus.
<hi>
Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. Aenean tincidunt diam sit amet semper vestibulum. Donec dictum dapibus magna vitae pharetra. Fusce condimentum velit at tempus aliquam. Maecenas maximus scelerisque nisi, et gravida felis molestie quis. Nunc nec mauris in ligula imperdiet rhoncus. Donec dignissim magna eu consectetur luctus.
Phasellus sed massa vitae nisl congue congue. Etiam nec luctus dolor, eget placerat ligula. Fusce mollis neque vitae fermentum gravida. Suspendisse maximus felis risus, vel fringilla mauris tristique quis. Orci varius natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Orci varius natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Interdum et malesuada fames ac ante ipsum primis in faucibum
</hi>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}