use strict;
my $str = ' At present, I believe the "deeply-involved" contributor would need to fork the \'content\' repo to their personal Github accounts, revise, and later do pull requests. An alternative workflow was considered that might involve more sophisticated use of Github, but after piloting it out, this seemed like it would be hard to explain and enforce consistent use, esp. with github newbies. This was overkill; though this project may contain very modest amounts of code, it is not a coding project for a software product! I decided that this is best left to user\'s individual workflow. Some explanation of best practice, etc. this is a test. (e.g. for pull requests) might still be needed for the proposed workflow, but this is a lighter burden than the alternative
This is a ttest.
This is a test. this is another test
This is a ttest.
This is a test. this is another test';
my $regex = qr/(?<!\w\.\w.|etc.)(?<=\.|\?|!)\s(?=\w)/mp;
my $subst = '\\r';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";