$re = '/((\-?\d*\-?\d+)\/(\d+$))|(^\-?\d+$)/m';
$str = '/ in str
3/5
33/55
-3/5
-33/55
/ not in str
3
-3
33
-33
carry
1-1/2
-1-1/2
#invalid
/
-
3/
/33
3-3
1-/2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);