# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"TASK\s\[(?P<task_name>[A-Za-z0-9_ -]+)\]\s\*+\n(?P<host_result_block>.*?((?=^TASK\s)|(?=^PLAY\sRECAP)))"
test_str = ("PLAY [Linux Hostname] **********************************************************\n\n"
"TASK [Gathering Facts] *********************************************************\n"
"ok: [LINUX1]\n"
"ok: [LINUX2]\n"
"fatal: [LINUX3]\n\n"
"TASK [Check Linux Hostname] ****************************************************\n"
"ok: [LINUX1]\n\n"
"PLAY RECAP *********************************************************************\n"
"LINUX1 : ok=2 changed=0 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0 \n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.