const regex = /<iframe[\s]+?src="(http[s]*:\/\/)?www\.youtube\.com\/embed\/([a-zA-Z0-9-_]{11})[^"]*"[^>]*?><\/iframe>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<iframe[\\s]+?src="(http[s]*:\\\/\\\/)?www\\.youtube\\.com\\\/embed\\\/([a-zA-Z0-9-_]{11})[^"]*"[^>]*?><\\\/iframe>', 'g')
const str = `<iframe src="https://www.youtube.com/embed/lfLRV19y6hg?disablekb=1&rel=0&showinfo=0" width="780" height="439" frameborder="0" allowfullscreen="allowfullscreen"></iframe>
<iframe src="https://www.youtube.com/embed/3xzCyOdf4Qc?disablekb=1&rel=0&showinfo=0" width="780" height="439" frameborder="0" allowfullscreen="allowfullscreen"></iframe>
<iframe src="https://www.youtube.com/embed/JtpT4LLxFv4?disablekb=1&rel=0&showinfo=0" width="780" height="440" frameborder="0" allowfullscreen="allowfullscreen"></iframe>
<iframe src="https://www.youtube.com/embed/R6UAHzmxJ_g?disablekb=1&rel=0&showinfo=0" width="780" height="439" frameborder="0" allowfullscreen="allowfullscreen"></iframe>
<iframe src="https://www.youtube.com/embed/DIFGObcX9A4?disablekb=1&rel=0&showinfo=0" width="780" height="439" frameborder="0" allowfullscreen="allowfullscreen"></iframe>
<iframe src="https://www.youtube.com/embed/HtDEqzAk_48?disablekb=1&rel=0&showinfo=0" width="780" height="439" frameborder="0" allowfullscreen="allowfullscreen"></iframe>
<iframe src="https://www.youtube.com/embed/n5GpN1Xa4q0?disablekb=1&rel=0&showinfo=0" width="780" height="439" frameborder="0" allowfullscreen="allowfullscreen"></iframe>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}