#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\(20(\d{2}|x{2})((\.|-)([0-9]{2}|x{2}|KW(\d{2}|x{2})|Q(x|[1-4])|(([0-9]{2}|x{2})(\.|-)([0-9]{2}|x{2}))))?\)"
Local $sString = "20000002000" & @CRLF & _
"200 0" & @CRLF & _
"(2022.xx2000.xx)" & @CRLF & _
"(2022.xx) 2000.xx" & @CRLF & _
"(2020-20)" & @CRLF & _
"(20xx-12)" & @CRLF & _
"(20xx.xx-11)" & @CRLF & _
"(2002-KW00.00)" & @CRLF & _
"(2002-KW00)" & @CRLF & _
"(2022.KWxx)" & @CRLF & _
"(2021.KW09)" & @CRLF & _
"(2021.KW09)" & @CRLF & _
"(2021.02)" & @CRLF & _
"2022.Qx" & @CRLF & _
"2032.Q4" & @CRLF & _
"(2020.xx)" & @CRLF & _
"2022-Q1" & @CRLF & _
"2022 Test" & @CRLF & _
"Test 20xx" & @CRLF & _
"" & @CRLF & _
"20202020" & @CRLF & _
".Qx" & @CRLF & _
"KW23" & @CRLF & _
"KWxx" & @CRLF & _
"(20xx)" & @CRLF & _
"(.-Q4)" & @CRLF & _
"" & @CRLF & _
"2000-" & @CRLF & _
"2000." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")