const regex = /^[a-z][a-z0-9]*(([A-Z][a-z0-9]+)*[A-Z]?|([a-z0-9]+[A-Z])*|[A-Z])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z][a-z0-9]*(([A-Z][a-z0-9]+)*[A-Z]?|([a-z0-9]+[A-Z])*|[A-Z])$', 'gm')
const str = `snake_case
PascalCase
2PascalCase
streamIOIO
gREATERDtha
modeADFAFdsADFads
aBabcABCDabcABC
modeADFdsADFads
streamIO
aBCabcABCabcA
aBCabcA
aabcABC
deviceSNS
pathASNs
dscpCP
awsVPC
deviceID
gREA1
gREAt
gREAtREAt
aABC
modeADFsADFads
modeADFads
createAMode
createBMode
contextHTMLParser
ibsReleaseTestVerificationRegressioNSuite
hELLO
camelCA
camel01CC01
camelCa_1
aabc123
a
ab
abc
abcd
abcde
camelCasecamelCasecamelCasecamelCasecamelCasecamelCase
aG
alphabet
cP3
a1
a1G
a123
camelCase
lThan30DaysCount
lessThan30DaysCount
lessThan30DaysCountA
greaterThan30LessThan60DaysCount
greaterThan60LessThan90DaysCount
greaterThan90DaysCount
pascalCase
pascal2Case
pascalCaseA
pascal2CaseA
modeA
mode2A
mode2A2
mode2A2A
madeEasy
wonderFul
andMe
htmlParser
h
aaA
camel01C
camel01c01
camel01C01
camel0a1c1
camel0a1C1
camel0ac1b1C1
camelC
camelC1
camelCa1
ibsReleaseTestVerificationRegressionSuite
ibsReleaseTestVerificationRegressioN
xmlHttpRequest
newCustomerId
innerStopwatch
supportsIpv6OnIos
youTubeImporter
youtubeImporter
affine3D`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}