$re = '/[a-z]+[\s,]+[n\.\°\s]*([\d]+[-\/\._]?[\d]*[a-z]*[\d]*|[s][n][c])[ ,]*.*/mi';
$str = 'P.ZZA DELLA COSTITUZIONE, N. 1/b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);