re = /([1-3]?\d)\s+(?:de\s+)?([A-Z][a-zç]{1,8})\s+(?:de\s+)?([12]\d{3})/m
str = 'João Fulano,123.456.789-00,21 de Maio de 1993,(21) 3079-9987,Rua do Ouvidor,50,20040-030,Rio de Janeiro
Maria Fulana, 98765432100,11 de Abril de 1995,(11) 933339871,Rua Vergueiro,3185,04101-300,São Paulo
denise teste, 987.654.321.00,28 de Dezembro de 1991,(31)45562712,SCS Qd. 8 Bl. B-50,11,70333-900,Rio Grande
denise teste, 987.654.321.00,28 Março 2023,(31)45562712,SCS Qd. 8 Bl. B-50,11,70333-900,Rio Grande'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end