# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(Semno_h)\b\s+(\w{50})"
test_str = ("CLUSTAL X (1.81) multiple sequence alignment\n\n\n"
"Maca_ma TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"M_tonke TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"Maca_ni TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"M_orchr TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"M_nemes TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"M_silen TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"M_siber TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCTACGATGAC\n"
"M_fusca TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"M_mulat TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"M_cyclo TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"M_fasci TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"M_arcto TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"M_thibe TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"M_sylva TGTG-TCTCACCATCT-TCCTACTCTCCACCACACTGAGCCCACGATGAC\n"
"P_anubi TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"P_hamad TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"Papi_Pa TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"L_albig TGTG-TCTCACCATCT-TCCTACTCTCCACTACCCTGAGCCCACGATGAC\n"
"L_aterr TGTG-TCTCACCATCT-TCCTACTCTCCACTACCCTGAGCCCACGATGAC\n"
"Tupa_ge TGTG-TCTCACCATCT-TCCTACTCTCCACTACCCTGAGCCCACGATGAC\n"
"Cb_agil TGTG-CCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"C_chrys TGTG-CCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"C_torqu TGTG-CCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"M_leuco TGTG-CCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"M_sphin TGTG-CCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"C_albog TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"cercop_ ??????????????????????????????????????????????????\n"
"C_ascan TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"Cerc_ce TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"C_petau TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"Cercop_ TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"C_wolfi TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACAATGAC\n"
"Cercop_ TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"C_negle TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"C_hamly TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"M_ogoue TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"C_aethi TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"C_sabae TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"C_cynos TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"Cer_lho TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"Erythro TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAGCCCACGATGAC\n"
"A_nigro TGTG-TCTCACCATCT-TCCCACTCTCCACTACACTGAGCCCACGATGAC\n"
"Tupa_ob TGTG-TCTCACCATCT-TTCTACTCGCCACTACACTGAGCCCATGATGAC\n"
"Tupa_ph TGTG-TCTCACCATCT-TTCTACTCGCCACTACACTGAGCCCATGATGAC\n"
"Tupa_au TGTG-TCTCACCATCT-TTCTACTCGCCACTACACTGAGCCCATGATGAC\n"
"Tupa_de TGTG-TCTCACCATCT-TTCTACTCGCCACTACACTGAGCCCATGATGAC\n"
"Tupa_fr ??????????????????????????????????????????????????\n"
"Tupa_ha TGTG-TCTCACCATCT-TTCTACTCGCCACTACACTGAGCCCATGATGAC\n"
"S_entel CGTG-TCTCACCATCT-TTCTACTCGCCACTACACTGAGCCTATGATGAC\n"
"Semno_h CGTG-TCTCACCATCT-TTCTACTCGCCACTACACTGAGCCTATGATGAC\n"
"S_entel TGTG-TCTCACCATCT-TTCTACTCGCCACTACACTGAGCCCATGATGAC\n"
"Tupa_ve TGTG-TCTCACCATCT-TTCTACTCGCCACTACACTGAGCCCATGATGAC\n"
"P_ciner TGTG-TCTCACCATCT-TTCTACTCGCCACTACACTGAGCCCATGATGAC\n"
"P_nemae TGTG-TCTCACCATCT-TTCTACTCGCCACTACACTGAGCCCATGATGAC\n"
"P_nigri TGTG-TCTCACCATCT-TTCTACTCGCCACTACACTGAGCCCATGATGAC\n"
"Nasalis TGTG-TCTCACCATCT-TTCTACTCGCCACTACACTGAGCCCATGATGAC\n"
"Rhinopi TGTG-TCTCACCATCT-TTCTACTCGCCACTACACTGAGCCCATGATGAC\n"
"Presb_c TGTG-TCTCACCATCT-TTCTACTCGCCACTACACTGAGCCCATGATGAC\n"
"P_melal TGTG-TCTCACCATCT-TTCTACTCGCCACTACACTGAGCCCATGATGAC\n"
"Cb_guer TGTG-TCTCCCCATCT-TTCTACTCGCCACTACACTGAGCCCATGATGAC\n"
"Cb_poly TGTG-TCTCACCATCT-TTCTACTCGCCACTACACTGAGCCCATGATGAC\n"
"Cb_ango TGTG-TCTCACCATCT-TTCTACTCGCCACTACACTGAGCCCATGATGAC\n"
"PilioCb TGTG-TCTCACCATCT-TTCTACTCGCCACTACACTGAGCCCATGAT-AC\n"
"hylo_ag TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAACCCACCATGAT\n"
"hylo_mu TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAACCCACCATGAT\n"
"hyloba_ TGTG-TCKCACCATCT-TCCTACTCTCCACTACACTGAACCCACCATGAT\n"
"Symphal TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAACCCACCATGAC\n"
"Nomas_l TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAACCCACCATGAT\n"
"Nomas_s TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAACCCACCATGAT\n"
"Nomas_c TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAACCCACCATGAT\n"
"Nomas_g TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAACCCACCATGAT\n"
"Ptroglo TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAACCCACAATGAC\n"
"P_trogl TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAACCCACAATGAC\n"
"Pan_pan TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAACCCACAATGAC\n"
"Homo_sa TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAACCCACAATGAC\n"
"Gorilla TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAACCCACAATGAC\n"
"png_abe TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAACCCACGATGAC\n"
"png_pyg TGTG-TCTCACCATCT-TCCTACTCTCCACTACACTGAACCCACGATGAC\n"
"Ca_jacc CGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"Ca_peni CGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"Ca_geof CGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"Ca_kuhl CGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"Ca_auri ??????????????????????????????????????????????????\n"
"Mico_ar CGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"Mico_hu CGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"Cebuell CGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"C_goeld TATG-TCTCTGCATCT-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"L_chrys TGCG-TCTCAGCATCC-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"L_rosal TGCG-TCTCAGCATCC-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"S_bicol TGTG-TCTCAGCATCT-TCCTGCTCTCCACCATACTGAGCCCAAGATGAC\n"
"S_marti TGTG-TCTCAGCCTCTATCCTGCTCTCCACCATACTGAGCCCAAGATGAC\n"
"S_midas TGTG-TCTCAGCATCT-TCCTGCTCTCCACCATACTGAGCCCAAGATGAC\n"
"S_geoff TGTG-TCTCAGCATCT-TCCTGCTCTCCACCATACTGAGCCCAAGATGAC\n"
"S_oedip TGTG-TCTCAGCATCT-TCCTGCTCTCCACCATACTGAGCCCAAGATGAC\n"
"S_labia TGTG-TCTCAGCATCT-TCCTGCTCTCCACCATACTGAGCCCAAGATGAC\n"
"S_mysta TGTG-TCTCAGCATCT-TCCTGCTCTCCACCATACTGAGCCCAAGATGAC\n"
"S_imper TGTG-TCTCAGCATCT-TCCTGCTCTCCACCATACTGAGCCCAAGATGAC\n"
"S_fusci TGTG-TCTCAGCATCT-TCCTGCTCTCYACCATACTGAGCCCAAGATGAC\n"
"A_azar_ TGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"A_azar_ TGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"Aot_aza TGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"A_nancy TGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGTGCCCAAGATGAC\n"
"A_Linus ??????????????????????????????????????????????????\n"
"A_trivi ??????????????????????????????????????????????????\n"
"C_robus ?????????AGCA-TT-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"C_xanth TGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"Cebs_ap TGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"C_capuc TGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"C_albif TGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"C_oliva TGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"S_oerst ?????????AGCATCT-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"S_sciur TGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCCCAAGATGAC\n"
"Saim_us ??????????????????????????????????????????????????\n"
"S_boliv ??????????????????????????????????????????????????\n"
"A_belze TGTG-TMTCAGAATCT-TCCTGCTCTCCACCACACTGAGCCCACCATGAC\n"
"A_geoff ??????????????????????????????????????????????????\n"
"A_hybri TGTG-TCTCAGAATCT-TCCTGCTCTCCACCACACTGAGCCCACCATGAC\n"
"A_fusci TGTG-TCTCAGAATCT-TCCTGCTCTCCACCACACTGAGCCCACCATGAC\n"
"Atel_ch TGTG-TCTCAGAATCT-TCCTGCTCTCCACCACACTGAGCCCACCATGAC\n"
"A_panis TGTG-TCTCAGAATCT-TCCTGCTCTCCACCACACTGAGCCCACCATGAC\n"
"B_arach TGTG-TCTCAGAATCT-TCCTGCTCTCCACCACACTGAGCCCACCATGAC\n"
"B_hypox CGTG-TCTCAGAATCT-TCCTGCTCTCCACCACACTGAGCCCACCATGAC\n"
"Lagot_c TGTG-TCTCAGAATCT-TCCTGCTCTCCACCACACCGAGCCCACCATGAC\n"
"L_lagot TGTG-TCTCAGAATCT-TCCTGCTCTCCACCACACCGAGCCCACCATGAC\n"
"A_belze CGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCACACAATGAT\n"
"Alouat_ CGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCACACGATGAT\n"
"Alout_S CGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCACACGATGAT\n"
"A_palli CGTG-TCTCAGCATCT-TCCTGCTCTCCACCACACTGAGCGCACGTTGAT\n"
"C_brunn ??????????????????????????????????????????????????\n"
"Callic_ TGTG-TCTTAGTATCT-TCCTGCTCTCCACCACACTGAGCCCACGATGAC\n"
"C_cupre TGTG-TCTTAGTATCT-TCCTGCTCTCCACCACACTGAGCCCACGATGAC\n"
"C_calig TGTG-TCTTAGTATCT-TCCTGCTCTCCACCACACTGAGCCCACGATGAC\n"
"C_donac TGTG-TCTTAGTATCT-TCCTGCTCTCCACCACACTGAGCCCACGATGAC\n"
"C_coimb TGTG-TCTTAGTATCT-TCCTGCTCTCCACCATACTGAGCCCACGATGAC\n"
"C_perso TGTG-TCTCAGTATCT--CCTGCT-CTCACCATACTGAGCCCACGATGAC\n"
"C_nigri ??????????????????????????????????????????????????\n"
"C_melan TGTG-TCTCAGCATCT-TCCTGCTCCCCACCACACTGAGCCCAAGATGAC\n"
"Cacaj_c TGTG-TCTCAGCATCT-TCCTGCTCCCCACCACACTGAGCCCACGATGAC\n"
"C_israe TGTG-TCTCAGCATCT-TCCTGCTCCCCACCACACTGAGCCCACGATGAC\n"
"C_satan TGTG-TCTCAGCATCT-TCCTGCTCCCCACCACACTGAGCCCACGATGAC\n"
"P_irror TGTG-TCTCAGCAT-T-TCCTGCTCCCCACCACACTGAGCCCACGATGAC\n"
"Papi_Pa TGTG-TCTCAGCATCT-TCCTGCTCCCCACCACACTGAGCCCACGATGAC\n"
"Tupa_ba CAT--CCTCAATGTCT-TTCTATTCTCTACCACGCTGAGCCCAGGATAAC\n"
"Tupa_sy GAT--CCTCAATGTCT-TTCTATTCTCCACCACGCTGAGCCCAGGATAAC\n"
"L_ankar TATG-TCCCAACATTT-TCTTATTCTCCACCGC--TGAGCYCARGATGAT\n"
"L_septe TATG-TCCCAACATTT-TCTTATTCTCCACCGC--TGAGCYCAGGATGAT\n"
"L_dorsa TATG-TCCCAACATTT-TCTTATTCTCCACCGC--TGAGCCCAGGATGAT\n"
"L_rufic TATG-TCCCAACATCT-CCTTATTTTCCACCGC--TGAGCCCAGGATGAT\n"
"Lepi_ja TATG-TCCCATCATTT-TCTTATTCTCCACTGC--TGAGCCCAGGATGAT\n"
"Microce -ATA-TCCCAACATTT-ACTTATTCTCCACCAC--TAAGCCCAGGATGAC\n"
"Microce ??????????????????????????????????????????????????\n"
"Mirza_z TATA-TCCCAACATCT-CCTTATTCTCCACCAC--TGAGCCCAGGATGAC\n"
"Chei_me -ATGTCCCCAACATCT----CATTCTCCACCAC--TGAGCCCAGGATGAC\n"
"P_ver_c ??????????????????????????????????????????????????\n"
"P_verre TATG-TCCCAACATCT-CCTTATTCTCCACCAC--TGAGYCTGGGATGAC\n"
"P_tatte TATG-TCCCAACATCT-CCTTATTCTCCACCAC--TGAGCCTGGGATGAC\n"
"P_diade TATG-TCCCAACATCT-CCTTATTCTCCACCAC--TGAGCCCGGGATGAC\n"
"P_edwar TATG-TCCCAACATCT-CCTTATTCTCCACCAC--TGAGCCCGGGATGAC\n"
"Avahi_l TATG-TCCCAACATCT-CCTTATTCTCCACCAC--TGAGCCCGGGATGAC\n"
"Eulem_r TATG-TCCCAAYATCT-CCTTATTCTCCACCAC--TGAGCCCGGGATGAC\n"
"E_colla TATG-TCCCAACATCT-CCTTATTCTCCACCAC--TGAGCCCGGGATGAC\n"
"Eul_ful TAKG-TCCCAACATCT-CCTTATTCTCCACCAC--TGAGCCGGGGATGAC\n"
"E_albif TATG-TCCCAACATCT-CCTTATTCTCCACCAC--TGAGCCSGGGATGAC\n"
"E_sanfo TATG-TCCCAACATCT-CCTTATTCTCCACCAC--TGAGCCGGGGATGAC\n"
"Eul_Mon TATG-TCCCAACATCT-CCTTATTCTCCACCAC--TGAGCCCGGGATGAC\n"
"Eul_mac TATG-TCCCAACATCT-CCTTATTCTCCACCAC--TGAGCCCGGGATGAC\n"
"EuMac_f TATG-TCCCAACATCT-CCTTATTCTCCACCAC--TTAGCCCGGGATGAC\n"
"E_coron TATG-TCCCAACATCT-CCTTATTCTCCACCAC--TGAGCCCGGGATGAC\n"
"E_rubri TATG-TCCCAACATCT-CCTTATTCTCCACCAC--TGAGCCCGGGATGAC\n"
"H_occid TATG-TCCCAAAAACT-CCTTATTCTCCACCAC--TGAGCCCAGGATGAC\n"
"H_grise TATG-TCCCAAAAACT-CCTTATTCTCCACCAC--TGAGCCCAGGATGAC\n"
"L_catta TATG-TCCCAACAACT-CCTTATTCTCCACCAC--TGAGCCCAGGATGAC\n"
"Vv_vari TATG-TCCCAACATCT-CCTTATTCTCCACCAC--TGAGCCCAGGATGAC\n"
"Vv_rubr TATG-TCCCAACATCT-CCTTATTCTCCACCAC--TGAGCCCAGGATGAC\n"
"Daubent ??????????????????????????????????????????????????\n"
"N_benga TATG-TCTCCACAGCT--CCTATTCTCTACCACAGTAAGCCCA-------\n"
"N_couca TATG-TCTCCACAGCT--CCTATTCTCTACCACAGTAAGCCCA-------\n"
"N_pygma TGTG-TCTCACCATCT-TCCTACTCTCCACTGCACTGAACCCACAATGAC\n"
"L_tardi ??????????????????????????????????????????????????\n"
"ArctoC_ TGTG-TCTCCCCATCT--CCTATTCTC---------TAACACACTAAGCC\n"
"Perodic TATG-TCTCCACATCT--CCCATTCTCTAACACACTAAGCCCA-------\n"
"O_garne ??????????????????????????????????????????????????\n"
"O_crass TATG-TCTCCACACCT--CCTATTCTCTACCACAATAAGCCCA-------\n"
"G_Galag ??????????????????????????????????????????????????\n"
"G_seneg ??????????????????????????????????????????????????\n"
"G_thoma TATG-TCTCCACACCT--CCTATTCTCTACCACACTAAGCCCA-------\n"
"Galeopt ??????????????????????????????????????????????????\n"
"Cynocep ??????????????????????????????????????????????????\n"
"Tupa_gl ??????????????????????????????????????????????????\n"
"Tupa_mi ??????????????????????????????????????????????????\n"
"rabbitr ??????????????????????????????????????????????????\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.