#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?sm)<div class='race-venue'.*?<h2>(.*?)<span class='race-venue-date'>(.*?)</span>.*?</h2>.*?<span class='meeting-type'>(.*?)</span>.*?Rail Position:</b>(.*?)<br><b>Dual Track Meeting:</b>(.*?)<br><b>Track Type:</b>(.*?)<br><b>Track Condition:</b>(.*?)<br><b>Weather:</b>(.*?)<br><b>Penetrometer:</b>(.*?)<br><b>Track Information:</b>(.*?)<br /></div>"
Local $sString = "<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">" & @CRLF & _
"<html xmlns="http://www.w3.org/1999/xhtml">" & @CRLF & _
"<head> " & @CRLF & _
" <meta http-equiv="content-type" content="text/html; charset=UTF-8"/>" & @CRLF & _
" <meta name="description" content="Racing Australia is the national industry body representing Thoroughbred racing in Australia. Australian Horse Racing results, Horse Racing Materials." />" & @CRLF & _
" <meta name="keywords" content="Horse Racing Results,Race Results,RISA,Racing Australia, Australia Horse Racing, Australia, RISAForm, Field, Form, Racing Form,horse, horse racing, tab result, racing, racing nsw, racing victoria, horse racing result, form, jockey, horse riding, equestrian, horse race result, greyhound racing, horse betting, betting horse" />" & @CRLF & _
" <title>Racing Australia | Horse Racing Results</title>" & @CRLF & _
" <link rel="shortcut icon" type="image/x-icon" href="/design/images/favicon_risa.ico"/>" & @CRLF & _
" <link href="/design/css/risa_web_style.css?v30" rel="stylesheet" type="text/css" />" & @CRLF & _
" <link href="/design/css/search.css?v6" rel="stylesheet" type="text/css" />" & @CRLF & _
" " & @CRLF & _
" <!--Racing Materials Style-->" & @CRLF & _
" " & @CRLF & _
" <!--Racing Materials JS-->" & @CRLF & _
" <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8.2/jquery.min.js"></script>" & @CRLF & _
" <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/swfobject/2.1/swfobject.js"></script>" & @CRLF & _
" <script type="text/javascript" src="/design/js/stickycontent.js"></script><!--Sticky Race Number Menu-->" & @CRLF & _
" <script type="text/javascript" src="/design/js/ddaccordion.js"></script>" & @CRLF & _
" <script type="text/javascript" src="/design/js/editable.js"></script>" & @CRLF & _
" <script type="text/javascript" src="/design/js/Generic.js"></script>" & @CRLF & _
" <script type="text/javascript" src="/design/js/jquery.autocomplete.js"></script> " & @CRLF & _
"" & @CRLF & _
" <!-- Google Tag Manager -->" & @CRLF & _
"<script> (function (w, d, s, l, i) {" & @CRLF & _
" w[l] = w[l] || []; w[l].push({ 'gtm.start':" & @CRLF & _
"new Date().getTime(), event: 'gtm.js'" & @CRLF & _
" }); var f = d.getElementsByTagName(s)[0]," & @CRLF & _
"j = d.createElement(s), dl = l != 'dataLayer' ? '&l=' + l : ''; j.async = true; j.src =" & @CRLF & _
"'https://www.googletagmanager.com/gtm.js?id=' + i + dl; f.parentNode.insertBefore(j, f);" & @CRLF & _
" })(window, document, 'script', 'dataLayer', 'GTM-MGS3GD7');</script>" & @CRLF & _
"<!-- End Google Tag Manager -->" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" <!-- imgSlider Javascript file -->" & @CRLF & _
" <link href="/design/slider/js-image-slider.css" rel="stylesheet" />" & @CRLF & _
" <script src="/design/slider/js-image-slider.js" type="text/javascript"></script>" & @CRLF & _
" " & @CRLF & _
" <!-- Begin iPhone/iPad detection code - Sets a global variable -->" & @CRLF & _
" <script type="text/javascript">" & @CRLF & _
" if ((navigator.userAgent.indexOf('iPhone') != -1) || (navigator.userAgent.indexOf('iPod') != -1) || (navigator.userAgent.indexOf('iPad') != -1)) {" & @CRLF & _
" var replaceSWF = 1;" & @CRLF & _
" } else {" & @CRLF & _
" var replaceSWF = 0;" & @CRLF & _
" }" & @CRLF & _
" function GoHome() {" & @CRLF & _
" window.location='/home.aspx';" & @CRLF & _
" }" & @CRLF & _
" </script>" & @CRLF & _
" <!-- End iPhone/iPad detection code -->" & @CRLF & _
" " & @CRLF & _
" <!--Asynchronous Code for google to track out bound clicks-->" & @CRLF & _
" <script type="text/javascript">" & @CRLF & _
" function recordOutboundLink(link, category, action) {" & @CRLF & _
" _gat._getTrackerByName()._trackEvent(category, action);" & @CRLF & _
" setTimeout('document.location = "' + link.href + '"', 100);" & @CRLF & _
" }" & @CRLF & _
" </script>" & @CRLF & _
" <!--End Asynchronous Code-->" & @CRLF & _
" " & @CRLF & _
" <!--Google Analytics Updated Tracking 13052011-->" & @CRLF & _
" <script type="text/javascript">" & @CRLF & _
"" & @CRLF & _
" var _gaq = _gaq || [];" & @CRLF & _
" _gaq.push(['_setAccount', 'UA-6444294-13']);" & @CRLF & _
" _gaq.push(['_setDomainName', '.risa.com.au']);" & @CRLF & _
" _gaq.push(['_trackPageview']);" & @CRLF & _
" " & @CRLF & _
" (function() {" & @CRLF & _
" var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;" & @CRLF & _
" ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';" & @CRLF & _
" var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);" & @CRLF & _
" })();" & @CRLF & _
" " & @CRLF & _
" </script>" & @CRLF & _
" " & @CRLF & _
" <script type="text/javascript">" & @CRLF & _
" function recordOutboundLink(link, category, action) {" & @CRLF & _
" try {" & @CRLF & _
" var pageTracker = _gat._getTracker("UA-6444294-13");" & @CRLF & _
" pageTracker._trackEvent(category, action);" & @CRLF & _
" setTimeout('document.location = "' + link.href + '"', 100)" & @CRLF & _
" }catch(err){}" & @CRLF & _
" }" & @CRLF & _
" </script>" & @CRLF & _
" <!-- End Google Analytics Updated Tracking 13052011-->" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" <!--Google Analytics Updated Tracking 13May2015-->" & @CRLF & _
"" & @CRLF & _
" <script type="text/javascript">" & @CRLF & _
" (function (i, s, o, g, r, a, m) {" & @CRLF & _
" i['GoogleAnalyticsObject'] = r; i[r] = i[r] || function () {" & @CRLF & _
" (i[r].q = i[r].q || []).push(arguments)" & @CRLF & _
" }, i[r].l = 1 * new Date(); a = s.createElement(o)," & @CRLF & _
" m = s.getElementsByTagName(o)[0]; a.async = 1; a.src = g; m.parentNode.insertBefore(a, m)" & @CRLF & _
" })(window, document, 'script', '//www.google-analytics.com/analytics.js', 'ga');" & @CRLF & _
"" & @CRLF & _
" ga('create', 'UA-6444294-13', 'auto');" & @CRLF & _
" ga('send', 'pageview');" & @CRLF & _
"" & @CRLF & _
" </script>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <!--Google Analytics Updated Tracking 13May2015-->" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"</head>" & @CRLF & _
"<body class='ShowQuickLinks'>" & @CRLF & _
"<div id="main">" & @CRLF & _
" <div id="main-content">" & @CRLF & _
" <div id="header" class="header">" & @CRLF & _
" <div id="header-logo">" & @CRLF & _
" <a href="/home.aspx" name="top"><img src='/design/images/Racing-Australia-Logo.png' width="200" height="58" alt="Racing Australia Logo" title="Racing Australia" border="0" /></a>" & @CRLF & _
" </div>" & @CRLF & _
" <!--" & @CRLF & _
" <div id="header-socialmedia">" & @CRLF & _
" <a href="https://www.facebook.com/RISA10" target="_blank"><img src="/design/images/Facebook.png" height="25" alt="Go to our Facebook Page" title="Go to our Facebook Page" border="0"></a>" & @CRLF & _
" <a href="https://twitter.com/#!/RacingAust" target="_blank"><img src="/design/images/Twitter.png" height="25" alt="Go to our Twitter Page" title="Go to our Twitter Page" border="0"></a>" & @CRLF & _
" " & @CRLF & _
" </div>" & @CRLF & _
" -->" & @CRLF & _
" " & @CRLF & _
" <ul class="header-top-menu">" & @CRLF & _
" <li><a href="https://myhorseracing.horse/#/site" target="_blank">My Horse Racing</a></li>" & @CRLF & _
" <li><a href="https://www.racingjobs.com.au/" target="_blank">Racing Jobs</a></li>" & @CRLF & _
" <li><a href="https://equinegeneticsresearchcentre.horse/" target="_blank">Equine Genetics Research Centre</a></li>" & @CRLF & _
" <li ><a href="https://tor.racingaustralia.horse/" target="_blank" >Trainer and Owner Reforms</a></li>" & @CRLF & _
" <a style="border: none;height: 19px;display: inline-block; vertical-align: middle;" href="https://twitter.com/RacingAust" target="_blank"><img border="0" src="/design/images/about_us/header-twitter.png"/></a> <a style="border: none;height: 19px;display: inline-block; vertical-align: middle; margin-right: 9px;" target="_blank" href="https://www.facebook.com/RISA10"><img border="0" src="/design/images/about_us/header-facebook.png"/></a>" & @CRLF & _
" </ul>" & @CRLF & _
" " & @CRLF & _
" </div>" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"<div id="main-menu">" & @CRLF & _
"<ul>" & @CRLF & _
" <li>" & @CRLF & _
" <a href="https://www.studbook.org.au/" target="_blank">AUSTRALIAN STUD BOOK</a>" & @CRLF & _
" </li>" & @CRLF & _
" " & @CRLF & _
" <li>" & @CRLF & _
" <a href="#">REGISTRAR OF RACEHORSES</a>" & @CRLF & _
" <ul class="sub-menu">" & @CRLF & _
" <li><a href="/RoR/AboutROR.aspx">About Registrar of Racehorses</a></li>" & @CRLF & _
" <li><a href="/RoR/RegisterHorse.aspx">Registering a Horse</a></li>" & @CRLF & _
" <li><a href="/FreeServices/horse_name_search.aspx">Horse Name Availability Search</a></li>" & @CRLF & _
" <li><a href="/RoR/RacehorseId.aspx">Racehorse Identification</a></li>" & @CRLF & _
" <li><a href="/RoR/TransferOwnership.aspx">Transfer Ownership / Change of Share Percentage</a></li>" & @CRLF & _
" <li><a href="/RoR/Leasing.aspx">Leasing a Racehorse</a></li>" & @CRLF & _
" <li><a href="/RoR/RegisterSyndicates.aspx">Register Syndicates</a></li>" & @CRLF & _
" <li><a href="/RoR/RacingOverseasHorses.aspx">Racing NZ & overseas horses in Australia</a></li>" & @CRLF & _
" <li><a href="/RoR/DuplicatePapers.aspx">Duplicate Papers</a></li>" & @CRLF & _
" <li><a href="/RoR/ChangingAHorseName.aspx">Changing a Horse’s name</a></li>" & @CRLF & _
" <li><a href="/RoR/ChangeOwnersDetails.aspx">Owners Contact Details</a></li>" & @CRLF & _
" <li><a href="/RoR/RegisteringColours.aspx">Registering Colours</a></li>" & @CRLF & _
" <li><a href="/RoR/Forms.aspx">Forms</a></li>" & @CRLF & _
" <li><a href="/FreeServices/Australian_Rules_Of_Racing.aspx">Australian Rules of Racing</a></li>" & @CRLF & _
" <li><a href="/RoR/RenamedHorses.aspx">Renamed Horses</a></li>" & @CRLF & _
" <!--<li><a href="/RoR/Login.aspx">Login</a></li>-->" & @CRLF & _
" <li><a href="/RoR/OwnersAssociations.aspx">Owners Associations</a></li>" & @CRLF & _
" " & @CRLF & _
" </ul>" & @CRLF & _
" </li>" & @CRLF & _
"" & @CRLF & _
" <li>" & @CRLF & _
" <a href="#">RACING MATERIALS</a>" & @CRLF & _
" <ul>" & @CRLF & _
" <li><a href="/FreeFields/Calendar.aspx?State=NSW">New South Wales</a></li>" & @CRLF & _
" <li><a href="/FreeFields/Calendar.aspx?State=VIC">Victoria</a></li>" & @CRLF & _
" <li><a href="/FreeFields/Calendar.aspx?State=QLD">Queensland</a></li>" & @CRLF & _
" <li><a href="/FreeFields/Calendar.aspx?State=WA">Western Australia</a></li>" & @CRLF & _
" <li><a href="/FreeFields/Calendar.aspx?State=SA">South Australia</a></li>" & @CRLF & _
" <li><a href="/FreeFields/Calendar.aspx?State=TAS">Tasmania</a></li>" & @CRLF & _
" <li><a href="/FreeFields/Calendar.aspx?State=ACT">Australian Capital Territory</a></li>" & @CRLF & _
" <li><a href="/FreeFields/Calendar.aspx?State=NT">Northern Territory</a></li>" & @CRLF & _
" <!--li><a href="/FreeFields/GroupAndListedRaces.aspx">Group & Listed Races / Classifications</a></li-->" & @CRLF & _
" </ul>" & @CRLF & _
" </li>" & @CRLF & _
" <!--li>" & @CRLF & _
" <a href="#">RULES & PUBLICATIONS</a>" & @CRLF & _
" <ul>" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" </ul>" & @CRLF & _
" </li-->" & @CRLF & _
"" & @CRLF & _
" <li class="login" style="margin-right: 14px !important;">" & @CRLF & _
" <a href="#" class="login-a">LOGINS</a>" & @CRLF & _
" <ul>" & @CRLF & _
" <li><a href="/IndustryLogin/SNS_Login.aspx">SNS</a></li>" & @CRLF & _
" <li><a href="/IndustryLogin/Stable_Assist_Login.aspx">Stable Assist</a></li>" & @CRLF & _
" <li><a target="_blank" href="https://studbook.org.au/">ASB Subscriptions</a></li>" & @CRLF & _
" <li><a href="/IndustryLogin/RSB_subscribers_Login.aspx">RSB Subscribers</a></li>" & @CRLF & _
" <!--li><a href="/IndustryLogin/Form_subscribers_Login.aspx">RISA Form Subscribers</a></li-->" & @CRLF & _
" <li><a href="/IndustryLogin/Connect_Login.aspx">Connect Login</a></li>" & @CRLF & _
" <li><a href="https://risa.webex.com" target="_blank">Webex</a></li> " & @CRLF & _
" <li><a href="/arb/Racingappeals.aspx">Racing Appeals</a></li>" & @CRLF & _
" </ul>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="about-us">" & @CRLF & _
" <a href="/ContactUs/default.aspx">ABOUT US</a>" & @CRLF & _
" <ul>" & @CRLF & _
" <li><a href="/Aboutus/Vision-Core-Functions.aspx">Vision & Core Functions</a></li>" & @CRLF & _
" <li><a href="/Aboutus/History.aspx">History</a></li>" & @CRLF & _
" <li><a href="/Aboutus/Role-and-Services.aspx">Our Role</a></li>" & @CRLF & _
" <li><a href="/Aboutus/Board.aspx">The Board</a></li>" & @CRLF & _
" <li><a href="/Aboutus/Management.aspx">The Team</a></li>" & @CRLF & _
" <li><a href="#">Publications                       ></a>" & @CRLF & _
" <ul style="padding-top:0px">" & @CRLF & _
" <li><a href="/Aboutus/AnnualReport.aspx">Annual Report</a></li>" & @CRLF & _
" <li><a href="/Aboutus/FactBook.aspx">Fact Book</a></li>" & @CRLF & _
" <li><a href="https://ier-study.racingaustralia.horse/">Industry Study</a></li>" & @CRLF & _
" </ul>" & @CRLF & _
" </li>" & @CRLF & _
" <li><a href="/FreeServices/Australian_Rules_Of_Racing.aspx">Australian Rules Of Racing</a></li>" & @CRLF & _
" <li><a href="/FreeServices/MediaReleases.aspx">Media Releases</a></li>" & @CRLF & _
" <!--li><a href="/Aboutus/sns.aspx">About SNS</a></li-->" & @CRLF & _
" <!--li><a href="#">Animal Welfare</a></li-->" & @CRLF & _
" <li><a href="/Licensing/Licensing.aspx">Licensing</a></li>" & @CRLF & _
" <li><a href="/FreeServices/PerformanceReport.aspx">Monthly Performance Report</a></li>" & @CRLF & _
" <li><a href="/ContactUs/">Contact Us</a></li>" & @CRLF & _
" <li><a href="/FAQ/FAQ.aspx">FAQ</a></li>" & @CRLF & _
" <li><a target="_blank" href="https://racingaustraliasystemsstatus.horse/">Racing Australia </br>Systems Status Updates</a></li>" & @CRLF & _
" </ul>" & @CRLF & _
" </li>" & @CRLF & _
" " & @CRLF & _
"</ul> " & @CRLF & _
"</div>" & @CRLF & _
" <div>" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" </div>" & @CRLF & _
" <div id="middle-container">" & @CRLF & _
" <div id="info-container">" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<div id="grey-content">" & @CRLF & _
" <div id="page-content">" & @CRLF & _
" <div class="state-specific-banner">" & @CRLF & _
"" & @CRLF & _
" <a href="https://www.racingqueensland.com.au/Going-to-the-races/Event-search?what=Thoroughbred" target="_blank" onClick="ga('send', 'event', 'Outbound Link', 'Click', '2019 RQ Winter Carnival');">" & @CRLF & _
" <img src='../../design/images/adverts/2019_Winter_QLD_Banner.jpg' width='728' height='90' alt='2019 RQ Winter Carnival' border='0'/></a>" & @CRLF & _
"" & @CRLF & _
" <img width='0' height='0' src="data:image/gif;base64,R0lGODlhAQABAIAAAP///////yH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" onload="ga('send', 'event', 'Outbound Link', 'Impression','2019 RQ Winter Carnival',0, {'nonInteraction': 1});"/>" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<div class="tab-menu">" & @CRLF & _
" <div class="inactive-tab"><a href="/FreeFields/RaceProgram.aspx?Key=2019Mar14%2CQLD%2CBeaudesert">Programs</a></div>" & @CRLF & _
" <div class="inactive-tab"><a href="/FreeFields/Nominations.aspx?Key=2019Mar14%2CQLD%2CBeaudesert">Nominations</a></div>" & @CRLF & _
" <div class="inactive-tab"><a href="/FreeFields/Weights.aspx?Key=2019Mar14%2CQLD%2CBeaudesert">Weights</a></div>" & @CRLF & _
" <div class="inactive-tab"><a href="/FreeFields/Acceptances.aspx?Key=2019Mar14%2CQLD%2CBeaudesert">Acceptances</a></div>" & @CRLF & _
" <div class="inactive-tab"><a href="/FreeFields/Form.aspx?Key=2019Mar14%2CQLD%2CBeaudesert&recentForm=Y">Recent Form</a></div>" & @CRLF & _
" <div class="inactive-tab"><a href="/FreeFields/AllForm.aspx?Key=2019Mar14%2CQLD%2CBeaudesert&recentForm=N">All Form</a></div>" & @CRLF & _
" <div class="inactive-tab"><a href="/FreeFields/GearChanges.aspx?Key=2019Mar14%2CQLD%2CBeaudesert">Gear</a></div>" & @CRLF & _
" <div class="inactive-tab"><a href="/FreeFields/Scratchings.aspx?Key=2019Mar14%2CQLD%2CBeaudesert">Scratchings</a></div>" & @CRLF & _
" <div class="active-tab"><a href="/FreeFields/Results.aspx?Key=2019Mar14%2CQLD%2CBeaudesert">Results</a></div>" & @CRLF & _
" " & @CRLF & _
"</div>" & @CRLF & _
"<div class="clear-space"> </div>" & @CRLF & _
"<div class='race-venue'>" & @CRLF & _
" <div class='top'>" & @CRLF & _
" <h2>" & @CRLF & _
" Beaudesert: Beaudesert Race Club" & @CRLF & _
" <span class='race-venue-date'>Thursday, 14 March 2019</span>" & @CRLF & _
" </h2>" & @CRLF & _
" <span class='meeting-type'>Meeting Type: Provincial (TAB MEETING)</span>" & @CRLF & _
" <div class="printer-friendly">" & @CRLF & _
" <a href='?Key=2019Mar14,QLD,Beaudesert&BodyClass=PrintFriendly' target='_blank'><img src="/design/images/print_friendly_btn.png" alt="Print Friendly Version" title="Print Friendly Version" border="0" width="30" height="19">Print Friendly</a>" & @CRLF & _
" </div> " & @CRLF & _
" </div>" & @CRLF & _
"</div>" & @CRLF & _
"<div class='race-venue-bottom'>" & @CRLF & _
"<div class='col1'><b>Rail Position:</b> +2m 700m-250m, Cutaway from 250m, True Remainder<br><b>Dual Track Meeting:</b> N<br><b>Track Type:</b> Turf<br><b>Track Condition:</b> Good 3<br><b>Weather:</b> Hot<br><b>Penetrometer:</b> <br><b>Track Information:</b> <br /></div><div class='col2'><b>Results Last Published:</b> Fri 15-Mar-19 11:08AM AEDT<br></div>" & @CRLF & _
" <div class='comments'>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")