import Foundation
let pattern = #"^/(?<page>quizzes)(?:/(?<subpage>[\w-]+)?)?(?:/)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# EXPECTED URL MATCHES
/quizzes
/quizzes/
/quizzes/food
/quizzes/food/
/quizzes.xml
/quizzes/food.xml
# EXPECTED URL NON-MATCHES
/quizzes2
/quizzes.xml/
/quizzes/food.xml/
/investigations
/investigations/foo
/jobs/something
/foo/bar
/jp/index
/about
/press
/uk/shopping
/esp/shopping
/shopping
/jp/shopping
/jp/quizzes
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)