$re = '/\s(?<subdomain>\S+)(\.\S+){2}\b/m';
$str = 'this is a test: sub.domain.google.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);