$re = '/^(\S+\s)Get\/(gradebook|assignments|activity)\/(?(?=\d+$)(\d*)|\d+\/(\d+))/m';
$str = '\'Viewed Get/assignments/333/3333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);