using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z0-9]*[a-zA-Z]+[a-zA-Z0-9]*\.[a-zA-Z0-9]*\.[a-zA-Z0-9]*|[a-zA-Z0-9]*\.[a-zA-Z0-9]*[a-zA-Z]+[a-zA-Z0-9]*\.[a-zA-Z0-9]*|[a-zA-Z0-9]*\.[a-zA-Z0-9]*\.[a-zA-Z0-9]*[a-zA-Z]+[a-zA-Z0-9]*)(~|\-|\+){0,1}[a-zA-Z0-9]+$";
string input = @"//good
rc0.05.00
0rc.05.00
0.rc05.00
0.05rc.00
rc0.rc05.00
rc0.05rc.00
rc0rc.rc05.00
rc0.rc05rc.00
rc0.rc05rc.rc00
rc0.rc05rc.00rc
0.0.0sr1+asdf
0.0.0sr1
errhand.LSD.asdf+dfsg
//bad
1.1
1.1.1
1.00.00
v1c.1.
1.v1c.
1.01.01~sdgf
1.v1c.asdf-sadf+asdf
~1c.1c.0
1c.1~c.0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}