import Foundation
let pattern = #"(?<=\s)x(?=\s\d?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
apple 10m
10mm
11ml
11kg
12g
13gr
14m3
15m2
apple 10 stuks
10 pieces
11 pces
11 pce
12 stk
13 stuks
14m3
15m2
ml x 1
ml X 10m
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)