$re = '/^(2[0-3]|[01]?[0-9]):([0-5][0-9])$/m';
$str = '0:45';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);