re = /(?:(?<!\\)\\(?:(\\\\)*)(?:[^\\]|$))/m
str = '\\
\\\\
\\\\\\
\\\\\\\\
bhuijiijiji\\\\\\
gerg\\\\\\\\gerge\\\\\\rgerg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end