$re = '/^application\/(.+\+)?json$/m';
$str = 'application/json
application/vnd.schemaregistry.v1+json';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);