const regex = new RegExp('(CAN_SID[A-Z0-9_]+(?=(_([A-Z0-9]{6}[0-9]))))|(NO_SIGNAL)', 'gm')
const str = `/* UACK */ {CAN_SID_UACK_IDT1S03, CAN_SID_N_UACK_0_IDT1S03}, {CAN_SID_UACK_IDT1S03, NO_SIGNAL},
{NO_SIGNAL, CAN_SID_UACK_IDT1S03},
{NO_SIGNAL, NO_SIGNAL},
{a, b }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}