#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?imx)^ " & @CRLF & _
"# Uncomment to allow prefix continuation (second letter of a dangling match)" & @CRLF & _
"# ([abcdefghiklmnoprstuvy\ ])?" & @CRLF & _
"( \" & @CRLF & _
" |(?: # Single-letter elements" & @CRLF & _
" [BCFHIKNOPSUVWY]" & @CRLF & _
" )" & @CRLF & _
" |(?: # Two-letter elements." & @CRLF & _
" (?:A[cglmrstu])|(?:B[aehikr])|(?:C[adeflmnorsu])|(?:D[bsy])" & @CRLF & _
" | (?:E[rsu])|(?:F[elmr])|(?:G[ade])|(?:H[efgos])|(?:I[nr])" & @CRLF & _
" | (?:K[r])|(?:L[airuv])|(?:M[cdgnot])|(?:N[abdehiop])" & @CRLF & _
" | (?:O[gs])|(?:P[abdmortu])|(?:R[abefghnu])|(?:S[bcegimnr])" & @CRLF & _
" | (?:T[abcehilms])|(?:X[e])|(?:Yb)|(?:Z[nr])" & @CRLF & _
" )" & @CRLF & _
" |(?: # Smushed trigrams. No need to go past trigrams because two twos make four" & @CRLF & _
" (?:A(?:ga|gd|ge|la|lr|md|mg|mt|ra|re|rg|ta|te|tl|tm))" & @CRLF & _
" |(?:E(?:ra|re|rg))" & @CRLF & _
" |(?:G(?:ag|al|am|ar|at|er))" & @CRLF & _
" |(?:L(?:ag|al|am|ar|at|ra|re|rg))" & @CRLF & _
" |(?:M(?:ga|gd|ge|ta|te|tl|tm))" & @CRLF & _
" |(?:R(?:ag|al|am|ar|at|er|ga|gd|ge))" & @CRLF & _
" |(?:T(?:ag|al|am|ar|at|er|la|lr|md|mg|mt))" & @CRLF & _
" |(?:X(?:er))" & @CRLF & _
" |(?:Z(?:ra|re|rg))" & @CRLF & _
" )" & @CRLF & _
"# repeated any number of times" & @CRLF & _
")+" & @CRLF & _
"# Uncomment to allow last letter if it's a potential first letter of the next word" & @CRLF & _
"# ([ADEGLMRTXZ]\ *)?" & @CRLF & _
"$"
Local $sString = "**(See bottom for Javascript/one-line version)**" & @CRLF & _
"If you want continuation -- to look for "fez" "rave" "rites" chains, strike the second and second-to-last lines. Latex needs a suffix and ear needs a prefix." & @CRLF & _
"latex" & @CRLF & _
"ear" & @CRLF & _
"latexear" & @CRLF & _
"fez" & @CRLF & _
"rave" & @CRLF & _
"rites" & @CRLF & _
"fezraverites" & @CRLF & _
"if you don't want overlap, comment out the big group with (?<=..) tests. Walter and lag will not match: lag is La + Ag but can't be L+Ag or La+G; walter is W+Al+Te+Er but there's no single A, L, T, E or R to make it a strict chain of elements." & @CRLF & _
"Walter" & @CRLF & _
"aga" & @CRLF & _
"McLvinandfezrobHogwartsWizrdsofMoney" & @CRLF & _
"## Match:" & @CRLF & _
"McLvIn" & @CRLF & _
"McLvinandfezrobHogwartsWizrdsofMoney" & @CRLF & _
"zr" & @CRLF & _
"McLvinand" & @CRLF & _
"ergo" & @CRLF & _
"Orgasmicallabkitscashflow" & @CRLF & _
"update" & @CRLF & _
"Organicfurbies" & @CRLF & _
"Babkes" & @CRLF & _
"WalterWhite" & @CRLF & _
"That" & @CRLF & _
"ibexesnogladybirds" & @CRLF & _
"Xenophobic" & @CRLF & _
"picnicforgus" & @CRLF & _
"snapes" & @CRLF & _
"siriusblack" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"## match until last letter, and last letter potentially starts a new word (allows continuation)" & @CRLF & _
"fez" & @CRLF & _
"McLvinandfez" & @CRLF & _
"bobatea" & @CRLF & _
"" & @CRLF & _
"# La + At + Te" & @CRLF & _
"late" & @CRLF & _
"# the x awaits an e in the next word" & @CRLF & _
"latex" & @CRLF & _
"# N + Nd + Dy + Y + Yb" & @CRLF & _
"ndyb" & @CRLF & _
"# the a is a potential continuation" & @CRLF & _
"andy" & @CRLF & _
"# ...but the x can't be a second letter" & @CRLF & _
"xndyb" & @CRLF & _
"" & @CRLF & _
"## Don't Match at some interior point in line" & @CRLF & _
"Jemmamead" & @CRLF & _
"## Don't Match anywhere in line" & @CRLF & _
"JemmaQmead" & @CRLF & _
"" & @CRLF & _
"### For Javascript:" & @CRLF & _
"" & @CRLF & _
"^([abcdefghiklmnoprstuvy\s])?(\ |(?:[BCFHIKNOPSUVWY])|(?:(?:A[cglmrstu])|(?:B[aehikr])|(?:C[adeflmnorsu])|(?:D[bsy])|(?:E[rsu])|(?:F[elmr])|(?:G[ade])|(?:H[efgos])|(?:I[nr])|(?:K[r])|(?:L[airuv])|(?:M[cdgnot])|(?:N[abdehiop])|(?:O[gs])|(?:P[abdmortu])|(?:R[abefghnu])|(?:S[bcegimnr])|(?:T[abcehilms])|(?:X[e])|(?:Yb)|(?:Z[nr]))|(?:(?:A(?:ga|gd|ge|la|lr|md|mg|mt|ra|re|rg|ta|te|tl|tm))|(?:E(?:ra|re|rg))|(?:G(?:ag|al|am|ar|at|er))|(?:L(?:ag|al|am|ar|at|ra|re|rg))|(?:M(?:ga|gd|ge|ta|te|tl|tm))|(?:R(?:ag|al|am|ar|at|er|ga|gd|ge))|(?:T(?:ag|al|am|ar|at|er|la|lr|md|mg|mt))|(?:X(?:er))|(?:Z(?:ra|re|rg))))+([ADEGLMRTXZ]\ *)?$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")