package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[ ]{2,}`)
var str = `a b c d f g h`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}