$re = '/[^AEOUI\P{Lu}]/';
$str = 'ABcDeFO!.
.½§1234567890!"#¤%&/()=?´@£${[]}~*\\\'¨-_.,;:><| åäö';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);