package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?{"EVENT_NAME":"(?<tag6>[^"]*)","EVENT_ID":"(?<action>[^"]*)","User_Id":"(?<login>[^"]*)","X_Corelation_ID":"(?<policy>[^"]*)","Client_IPAddress":"(?<sip>[^"]*)","Acting_As_ID":"(?<account>[^"]*)","Message":"(?<tag2>[^"]*)"}`)
var str = `[2019-01-15 13:44:43,432] [[ACTIVE] ExecuteThread: '45' for queue: 'weblogic.kernel.Default (self-tuning)'] WARN SiemLogger - {"EVENT_NAME":"SIEM","EVENT_ID":"LOGOUT","User_Id":"ROBKNT1810","X_Corelation_ID":"null","Client_IPAddress":"null","Acting_As_ID":"null","Message":"MobileSignOutPage - User successfully logged out."}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}