package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(g|l|m|k)\w*`)
var str = `km`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}