import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "CREATE TABLE \\[dbo\\]\\.\\[[\\w\\-_]+_(?:Australia|Cesky|Deutsch|English|EnglishInternational|Francais|Italian|Nederlands|Polish|Romanian|Russian|Spanish|USEnglish|USFrench)\\].+?\\)\\;\\s";
final String string = "CREATE TABLE [dbo].[ASVersion]\n"
+ "(\n"
+ " [Attribute] [NVARCHAR](255) NOT NULL\n"
+ " , [Value] [NVARCHAR](255) NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([Attribute])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[INFO]\n"
+ "(\n"
+ " [Short] [NVARCHAR](50) NOT NULL\n"
+ " , [Long] [NVARCHAR](MAX) NULL\n"
+ " , [Status] [NVARCHAR](255) NULL\n"
+ " , [CountrificationInfo] [NVARCHAR](255) NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([Short])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[INFOSTATUS]\n"
+ "(\n"
+ " [Key] [INT] NOT NULL IDENTITY(0,1)\n"
+ " , [Statusname] [NVARCHAR](50) NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([Key])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[InfoTableRelations]\n"
+ "(\n"
+ " [Key] [INT] NOT NULL IDENTITY(0,1)\n"
+ " , [TableName] [NVARCHAR](255) NULL\n"
+ " , [ColumnName] [NVARCHAR](255) NULL\n"
+ " , [TypeProperty] [NVARCHAR](255) NULL\n"
+ " , [ReferToDB] [NVARCHAR](255) NULL\n"
+ " , [ReferToTable] [NVARCHAR](255) NULL\n"
+ " , [ReferToBindedColumn] [NVARCHAR](255) NULL\n"
+ " , [ReferToDisplayedColumn] [NVARCHAR](255) NULL\n"
+ " , [PropertyValue] [NVARCHAR](255) NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([Key])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[InfoTableRelations_AddIn]\n"
+ "(\n"
+ " [Key] [INT] NOT NULL IDENTITY(0,1)\n"
+ " , [TableName] [NVARCHAR](255) NULL\n"
+ " , [ColumnName] [NVARCHAR](255) NULL\n"
+ " , [TypeProperty] [NVARCHAR](255) NULL\n"
+ " , [ReferToDB] [NVARCHAR](255) NULL\n"
+ " , [ReferToTable] [NVARCHAR](255) NULL\n"
+ " , [ReferToBindedColumn] [NVARCHAR](255) NULL\n"
+ " , [ReferToDisplayedColumn] [NVARCHAR](255) NULL\n"
+ " , [PropertyValue] [NVARCHAR](255) NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([Key])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesCategories]\n"
+ "(\n"
+ " [ID] [INT] NOT NULL\n"
+ " , [RunName] [NVARCHAR](255) NULL\n"
+ " , [Deutsch] [NVARCHAR](50) NULL\n"
+ " , [English] [NVARCHAR](50) NULL\n"
+ " , [Nederlands] [NVARCHAR](50) NULL\n"
+ " , [Francais] [NVARCHAR](50) NULL\n"
+ " , [Cesky] [NVARCHAR](50) NULL\n"
+ " , [Russian] [NVARCHAR](50) NULL\n"
+ " , [Polish] [NVARCHAR](50) NULL\n"
+ " , [USFrench] [NVARCHAR](50) NULL\n"
+ " , [USEnglish] [NVARCHAR](50) NULL\n"
+ " , [EnglishInternational] [NVARCHAR](50) NULL\n"
+ " , [Spanish] [NVARCHAR](50) NULL\n"
+ " , [Italian] [NVARCHAR](50) NULL\n"
+ " , [Chinese] [NVARCHAR](50) NULL\n"
+ " , [Japanese] [NVARCHAR](50) NULL\n"
+ " , [Greek] [NVARCHAR](50) NULL\n"
+ " , [SouthAfrica] [NVARCHAR](50) NULL\n"
+ " , [Portuguese] [NVARCHAR](50) NULL\n"
+ " , [Indian] [NVARCHAR](50) NULL\n"
+ " , [Romanian] [NVARCHAR](50) NULL\n"
+ " , [SpanishAmericas] [NVARCHAR](50) NULL\n"
+ " , [Hungarian] [NVARCHAR](50) NULL\n"
+ " , [TraditionalChinese] [NVARCHAR](255) NULL\n"
+ " , [Bulgarian] [NVARCHAR](255) NULL\n"
+ " , [Turkish] [NVARCHAR](255) NULL\n"
+ " , [BrazilPortuguese] [NVARCHAR](255) NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([ID])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesCategoriesAssignment]\n"
+ "(\n"
+ " [TypeID] [INT] NOT NULL\n"
+ " , [CategoryID] [INT] NOT NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([TypeID], [CategoryID])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesGroupBy]\n"
+ "(\n"
+ " [TableID] [INT] NOT NULL\n"
+ " , [ColumnName] [NVARCHAR](255) NULL\n"
+ " , [GroupByTableID] [INT] NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([TableID])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesItems]\n"
+ "(\n"
+ " [TypeID] [INT] NOT NULL\n"
+ " , [CategoryID] [INT] NOT NULL\n"
+ " , [ProfileID] [INT] NOT NULL\n"
+ " , [TableID] [INT] NOT NULL\n"
+ " , [KeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , [MasterTableID] [INT] NOT NULL\n"
+ " , [MasterKeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([TypeID], [CategoryID], [ProfileID], [TableID], [KeyValue], [MasterTableID], [MasterKeyValue])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesItems_Australia]\n"
+ "(\n"
+ " [TypeID] [INT] NOT NULL\n"
+ " , [CategoryID] [INT] NOT NULL\n"
+ " , [ProfileID] [INT] NOT NULL\n"
+ " , [TableID] [INT] NOT NULL\n"
+ " , [KeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , [MasterTableID] [INT] NOT NULL\n"
+ " , [MasterKeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([TypeID], [CategoryID], [ProfileID], [TableID], [KeyValue], [MasterTableID], [MasterKeyValue])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesItems_Cesky]\n"
+ "(\n"
+ " [TypeID] [INT] NOT NULL\n"
+ " , [CategoryID] [INT] NOT NULL\n"
+ " , [ProfileID] [INT] NOT NULL\n"
+ " , [TableID] [INT] NOT NULL\n"
+ " , [KeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , [MasterTableID] [INT] NOT NULL\n"
+ " , [MasterKeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([TypeID], [CategoryID], [ProfileID], [TableID], [KeyValue], [MasterTableID], [MasterKeyValue])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesItems_Deutsch]\n"
+ "(\n"
+ " [TypeID] [INT] NOT NULL\n"
+ " , [CategoryID] [INT] NOT NULL\n"
+ " , [ProfileID] [INT] NOT NULL\n"
+ " , [TableID] [INT] NOT NULL\n"
+ " , [KeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , [MasterTableID] [INT] NOT NULL\n"
+ " , [MasterKeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([TypeID], [CategoryID], [ProfileID], [TableID], [KeyValue], [MasterTableID], [MasterKeyValue])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesItems_English]\n"
+ "(\n"
+ " [TypeID] [INT] NOT NULL\n"
+ " , [CategoryID] [INT] NOT NULL\n"
+ " , [ProfileID] [INT] NOT NULL\n"
+ " , [TableID] [INT] NOT NULL\n"
+ " , [KeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , [MasterTableID] [INT] NOT NULL\n"
+ " , [MasterKeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([TypeID], [CategoryID], [ProfileID], [TableID], [KeyValue], [MasterTableID], [MasterKeyValue])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesItems_EnglishInternational]\n"
+ "(\n"
+ " [TypeID] [INT] NOT NULL\n"
+ " , [CategoryID] [INT] NOT NULL\n"
+ " , [ProfileID] [INT] NOT NULL\n"
+ " , [TableID] [INT] NOT NULL\n"
+ " , [KeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , [MasterTableID] [INT] NOT NULL\n"
+ " , [MasterKeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([TypeID], [CategoryID], [ProfileID], [TableID], [KeyValue], [MasterTableID], [MasterKeyValue])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesItems_Francais]\n"
+ "(\n"
+ " [TypeID] [INT] NOT NULL\n"
+ " , [CategoryID] [INT] NOT NULL\n"
+ " , [ProfileID] [INT] NOT NULL\n"
+ " , [TableID] [INT] NOT NULL\n"
+ " , [KeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , [MasterTableID] [INT] NOT NULL\n"
+ " , [MasterKeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([TypeID], [CategoryID], [ProfileID], [TableID], [KeyValue], [MasterTableID], [MasterKeyValue])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesItems_Italian]\n"
+ "(\n"
+ " [TypeID] [INT] NOT NULL\n"
+ " , [CategoryID] [INT] NOT NULL\n"
+ " , [ProfileID] [INT] NOT NULL\n"
+ " , [TableID] [INT] NOT NULL\n"
+ " , [KeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , [MasterTableID] [INT] NOT NULL\n"
+ " , [MasterKeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([TypeID], [CategoryID], [ProfileID], [TableID], [KeyValue], [MasterTableID], [MasterKeyValue])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesItems_Nederlands]\n"
+ "(\n"
+ " [TypeID] [INT] NOT NULL\n"
+ " , [CategoryID] [INT] NOT NULL\n"
+ " , [ProfileID] [INT] NOT NULL\n"
+ " , [TableID] [INT] NOT NULL\n"
+ " , [KeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , [MasterTableID] [INT] NOT NULL\n"
+ " , [MasterKeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([TypeID], [CategoryID], [ProfileID], [TableID], [KeyValue], [MasterTableID], [MasterKeyValue])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesItems_Polish]\n"
+ "(\n"
+ " [TypeID] [INT] NOT NULL\n"
+ " , [CategoryID] [INT] NOT NULL\n"
+ " , [ProfileID] [INT] NOT NULL\n"
+ " , [TableID] [INT] NOT NULL\n"
+ " , [KeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , [MasterTableID] [INT] NOT NULL\n"
+ " , [MasterKeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([TypeID], [CategoryID], [ProfileID], [TableID], [KeyValue], [MasterTableID], [MasterKeyValue])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesItems_Romanian]\n"
+ "(\n"
+ " [TypeID] [INT] NOT NULL\n"
+ " , [CategoryID] [INT] NOT NULL\n"
+ " , [ProfileID] [INT] NOT NULL\n"
+ " , [TableID] [INT] NOT NULL\n"
+ " , [KeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , [MasterTableID] [INT] NOT NULL\n"
+ " , [MasterKeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([TypeID], [CategoryID], [ProfileID], [TableID], [KeyValue], [MasterTableID], [MasterKeyValue])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesItems_Russian]\n"
+ "(\n"
+ " [TypeID] [INT] NOT NULL\n"
+ " , [CategoryID] [INT] NOT NULL\n"
+ " , [ProfileID] [INT] NOT NULL\n"
+ " , [TableID] [INT] NOT NULL\n"
+ " , [KeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , [MasterTableID] [INT] NOT NULL\n"
+ " , [MasterKeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([TypeID], [CategoryID], [ProfileID], [TableID], [KeyValue], [MasterTableID], [MasterKeyValue])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesItems_USEnglish]\n"
+ "(\n"
+ " [TypeID] [INT] NOT NULL\n"
+ " , [CategoryID] [INT] NOT NULL\n"
+ " , [ProfileID] [INT] NOT NULL\n"
+ " , [TableID] [INT] NOT NULL\n"
+ " , [KeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , [MasterTableID] [INT] NOT NULL\n"
+ " , [MasterKeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([TypeID], [CategoryID], [ProfileID], [TableID], [KeyValue], [MasterTableID], [MasterKeyValue])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesItems_USFrench]\n"
+ "(\n"
+ " [TypeID] [INT] NOT NULL\n"
+ " , [CategoryID] [INT] NOT NULL\n"
+ " , [ProfileID] [INT] NOT NULL\n"
+ " , [TableID] [INT] NOT NULL\n"
+ " , [KeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , [MasterTableID] [INT] NOT NULL\n"
+ " , [MasterKeyValue] [NVARCHAR](255) NOT NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([TypeID], [CategoryID], [ProfileID], [TableID], [KeyValue], [MasterTableID], [MasterKeyValue])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesProfiles]\n"
+ "(\n"
+ " [ID] [INT] NOT NULL\n"
+ " , [RunName] [NVARCHAR](50) NULL\n"
+ " , [Country] [INT] NULL\n"
+ " , [Selected] [BIT] NOT NULL\n"
+ " , [Deutsch] [NVARCHAR](50) NULL\n"
+ " , [English] [NVARCHAR](50) NULL\n"
+ " , [Nederlands] [NVARCHAR](50) NULL\n"
+ " , [Francais] [NVARCHAR](50) NULL\n"
+ " , [Cesky] [NVARCHAR](50) NULL\n"
+ " , [Russian] [NVARCHAR](50) NULL\n"
+ " , [Polish] [NVARCHAR](50) NULL\n"
+ " , [USFrench] [NVARCHAR](50) NULL\n"
+ " , [USEnglish] [NVARCHAR](50) NULL\n"
+ " , [EnglishInternational] [NVARCHAR](50) NULL\n"
+ " , [Spanish] [NVARCHAR](50) NULL\n"
+ " , [Italian] [NVARCHAR](50) NULL\n"
+ " , [Chinese] [NVARCHAR](50) NULL\n"
+ " , [Japanese] [NVARCHAR](50) NULL\n"
+ " , [Greek] [NVARCHAR](50) NULL\n"
+ " , [SouthAfrica] [NVARCHAR](50) NULL\n"
+ " , [Portuguese] [NVARCHAR](50) NULL\n"
+ " , [Indian] [NVARCHAR](50) NULL\n"
+ " , [Romanian] [NVARCHAR](50) NULL\n"
+ " , [SpanishAmericas] [NVARCHAR](50) NULL\n"
+ " , [Hungarian] [NVARCHAR](50) NULL\n"
+ " , [TraditionalChinese] [NVARCHAR](50) NULL\n"
+ " , [Bulgarian] [NVARCHAR](50) NULL\n"
+ " , [Turkish] [NVARCHAR](50) NULL\n"
+ " , [BrazilPortuguese] [NVARCHAR](50) NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([ID])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesTables]\n"
+ "(\n"
+ " [ID] [INT] NOT NULL\n"
+ " , [TableName] [NVARCHAR](255) NULL\n"
+ " , [DatabaseName] [NVARCHAR](255) NULL\n"
+ " , [KeyColumnName] [NVARCHAR](255) NULL\n"
+ " , [KeyColumnType] [NVARCHAR](255) NULL\n"
+ " , [RunNameColumnName] [NVARCHAR](255) NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([ID])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesTablesRelations]\n"
+ "(\n"
+ " [MasterTableID] [INT] NOT NULL\n"
+ " , [SubTableID] [INT] NOT NULL\n"
+ " , [MasterTableColumnName] [NVARCHAR](255) NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([MasterTableID], [SubTableID])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesTypes]\n"
+ "(\n"
+ " [ID] [INT] NOT NULL\n"
+ " , [RunName] [NVARCHAR](255) NULL\n"
+ " , [Comment] [NVARCHAR](50) NULL\n"
+ " , [Deutsch] [NVARCHAR](50) NULL\n"
+ " , [English] [NVARCHAR](50) NULL\n"
+ " , [Nederlands] [NVARCHAR](50) NULL\n"
+ " , [Francais] [NVARCHAR](50) NULL\n"
+ " , [Cesky] [NVARCHAR](50) NULL\n"
+ " , [Russian] [NVARCHAR](50) NULL\n"
+ " , [Polish] [NVARCHAR](50) NULL\n"
+ " , [USFrench] [NVARCHAR](50) NULL\n"
+ " , [USEnglish] [NVARCHAR](50) NULL\n"
+ " , [EnglishInternational] [NVARCHAR](50) NULL\n"
+ " , [Spanish] [NVARCHAR](50) NULL\n"
+ " , [Italian] [NVARCHAR](50) NULL\n"
+ " , [Chinese] [NVARCHAR](50) NULL\n"
+ " , [Japanese] [NVARCHAR](50) NULL\n"
+ " , [Greek] [NVARCHAR](50) NULL\n"
+ " , [SouthAfrica] [NVARCHAR](50) NULL\n"
+ " , [Portuguese] [NVARCHAR](50) NULL\n"
+ " , [Indian] [NVARCHAR](50) NULL\n"
+ " , [Romanian] [NVARCHAR](50) NULL\n"
+ " , [SpanishAmericas] [NVARCHAR](50) NULL\n"
+ " , [Hungarian] [NVARCHAR](50) NULL\n"
+ " , [TraditionalChinese] [NVARCHAR](255) NULL\n"
+ " , [Bulgarian] [NVARCHAR](255) NULL\n"
+ " , [Turkish] [NVARCHAR](255) NULL\n"
+ " , [BrazilPortuguese] [NVARCHAR](255) NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([ID])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesTypesRelations]\n"
+ "(\n"
+ " [TypeID] [INT] NOT NULL\n"
+ " , [TableID] [INT] NOT NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([TypeID], [TableID])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[PreferredSizesTypeSubCategories]\n"
+ "(\n"
+ " [TypeID] [INT] NOT NULL\n"
+ " , [SubCategoryName] [NVARCHAR](50) NOT NULL\n"
+ " , [Deutsch] [NVARCHAR](50) NULL\n"
+ " , [English] [NVARCHAR](50) NULL\n"
+ " , [Nederlands] [NVARCHAR](50) NULL\n"
+ " , [Francais] [NVARCHAR](50) NULL\n"
+ " , [Cesky] [NVARCHAR](50) NULL\n"
+ " , [Russian] [NVARCHAR](50) NULL\n"
+ " , [Polish] [NVARCHAR](50) NULL\n"
+ " , [USFrench] [NVARCHAR](50) NULL\n"
+ " , [USEnglish] [NVARCHAR](50) NULL\n"
+ " , [EnglishInternational] [NVARCHAR](50) NULL\n"
+ " , [Spanish] [NVARCHAR](50) NULL\n"
+ " , [Italian] [NVARCHAR](50) NULL\n"
+ " , [Chinese] [NVARCHAR](50) NULL\n"
+ " , [Japanese] [NVARCHAR](50) NULL\n"
+ " , [Greek] [NVARCHAR](50) NULL\n"
+ " , [SouthAfrica] [NVARCHAR](50) NULL\n"
+ " , [Portuguese] [NVARCHAR](50) NULL\n"
+ " , [Indian] [NVARCHAR](50) NULL\n"
+ " , [Romanian] [NVARCHAR](50) NULL\n"
+ " , [SpanishAmericas] [NVARCHAR](50) NULL\n"
+ " , [Hungarian] [NVARCHAR](50) NULL\n"
+ " , [TraditionalChinese] [NVARCHAR](255) NULL\n"
+ " , [Bulgarian] [NVARCHAR](50) NULL\n"
+ " , [Turkish] [NVARCHAR](50) NULL\n"
+ " , [BrazilPortuguese] [NVARCHAR](50) NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([TypeID], [SubCategoryName])\n"
+ ");\n"
+ "CREATE TABLE [dbo].[UpDateTable]\n"
+ "(\n"
+ " [ID] [INT] NOT NULL\n"
+ " , [DSN] [NVARCHAR](50) NULL\n"
+ " , [SourceTable] [NVARCHAR](50) NULL\n"
+ " , [TargetTable] [NVARCHAR](50) NULL\n"
+ " , [forDelete] [BIT] NOT NULL\n"
+ " , [copyTable] [BIT] NOT NULL\n"
+ " , [CopyIfNotExist] [BIT] NOT NULL\n"
+ " , CONSTRAINT [] PRIMARY KEY CLUSTERED ([ID])\n"
+ ");\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}