$re = '/^\d{1,2}(,\d{0,1})?$/m';
$str = '22,2
222
21,33
abc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);