# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^0-9]*\b(([1-9]|1[0-9]|22|2[4-9]|[3-9][0-9]|1[0-2][0-9]|13[0-6]|1[4-9][0-9]|[2-9][0-9][0-8]|[1-9][0-9]{3}|[1-5][0-9]{4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-5])\b[^0-9]*)*$)"
test_str = ("56;45;5623;67;21;68\n"
"45;568;56564;68;254;136\n"
"8080;8958;368;65;80;443;22\n"
"8080;22;140\n"
"139;852;21;80\n"
"65;80;135\n"
"65;139\n"
"54;98;35;65;2 ;45\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.