package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)`)
var str = `221.65.178.8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}