using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^{([a-zA-Z0-9_\.]+)?(,[a-zA-Z0-9_\.]+)*}$";
string input = @"{a.b.c,d.ef}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}