const regex = /(?:(?:\.\.\/?)+[a-zA-Z0-9\/\._-]{1,})+(?:(?:jpe?g|png|gif|bmp|webp|pna|tiff|svg))/gsim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:\\.\\.\\\/?)+[a-zA-Z0-9\\\/\\._-]{1,})+(?:(?:jpe?g|png|gif|bmp|webp|pna|tiff|svg))', 'gsim')
const str = `https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpg
src="../c624121/v624121992/3cf22/YRIx_w-QySg.png"
src="../c624121/v624121992/3cf22/YRIx_w-QySg.jpg"
src="../c624121/v624121992/3cf22/YRIx_w-QySg.bmp"
src="../c624121/v624121992/3cf22/YRIx_w-QySg.tiff"
src="../c624121/v624121992/3cf22/YRIx_w-QySg.webp"
src="../c624121/v624121992/3cf22/YRIx_w-QySg.pna"
src="../c624121/v624121992/3cf22/YRIx_w-QySg.svg"
src="../c624121/v624121992/3cf22/YRIx_w-QySg.jpeg"
src="../c624121/v624121992/3cf22/YRIx_w-QySg.gif"
https://pp.vk.me/c624121/v624121992/3cf22/jpg/YRIx_w-QySg.jpg
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.png
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.bmp
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.gif
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpeg
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.webp
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.tiff
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.pna
https://pp.vk.me/c624121/v624121992/3cf22/svg/YRIx_w-QySg.svg
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}