re = /incorporation|\binc[.]*(?!\w)/mi
str = 'Inc
Inc.
Incorporation
My Inc
My Inc.
My Inc. Company
My Incorporation company
Linc Communication Llc
DRV Incorporated'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end