# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:.*[\/\\])?(?<FileNameWithoutExtension>.*)\.(.*?(?=\#|\?|$))"
test_str = ("http://www.cultureandcosmos.org/pdfs/2-2/Voss_Music_Spheres.pdf#456\n\n"
"https://static1.squarespace.com/static/58d6b5ff86e6c087a92f8f89/t/5913df9915cf7db9454ad94a/1494474655305/Plato_and_Hesiod.pdf#page=270\n\n"
"http://www.cultureandcosmos.org/pdfs/2-2/Voss_Music_Spheres.pdf?power=222p#11\n\n"
"https://archive.flossmanuals.net/inkscape/_booki/inkscape/inkscape.pdf\n\n\n"
"Taylor Swift - New Romantics.m4a\n"
"YT/Subto2mp3/Taylor Swift - New Terribly Romantics.m4a\n"
"Grow - Conan Blue (Official Video) has already been recorded in archive.m4a\n"
"PowerOptim Iol/Techno/(Official Video) Blue Burrow was already been recorded in archive - Bak.wm4\n"
"/Great Bun/Output Files/çè/Grow - Conan DARK (Official AUDIO) has already been recorded in archive.m4b\n"
"Matter Oil_9999.zip\n"
"Qpl$-pol.hrlp/perm.ui.pol/i op/doesn't matter.mp4\n"
"Small Laser4.m4a\n"
"manicur pliu/love is in the a°°_II+?§@R.txt\n"
"^Level09\\\\Power Pol\\energy.m4a\n"
"lollller_blllade 1987 (c)/super €/music_piece_.mp3\n"
"\\.\\.$./../../loli( u1990) _98.lop.pl/fil l/fill2asm.aile.asm.gz.zip\n"
"/Taylor Swift - New Romantics._m4a\n"
"\\$/Subto2/mp3/Taylor Swift -&- New Romantics.m4a\n"
"/Grow - Conan Gray (Official Video) has already been recorded in archive.m4a\n"
"C:\\PowerOptim Iol/Grow - The New Gray (Official Video) has been recorded [<1999>.wm4\n"
"/Great Bun/Output Files/çè/Grow - WiLlL(O)W Gray \"unofficial\" video has not been recorded in archive.m4b\n"
"/Matter Oil_9999.zip\n"
"file:///Qpl$-pol.hrlp/perm.ui.pol/i op/matter.mp4\n"
"/£¥«^6<4>à_»Laser4 ``[12{2%}32]deg`‘.webm\n"
"manicur pliu/great.power.great.responsibility?.gz.tar.zip\n"
"./poi kiol/greater.power.greater.responsibility!.gz.tar.zip\n"
"^Level09\\Power Pol\\energy.m4a\n"
"lollller_blllade 1987 (c)/super €/music_piece_.mp3\n"
"/The 'great' solitude of zorro #12/the 退ellent urge_for.mo.tar.gz\n\n\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.