package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(^[^-\ ]+)(\s[^-][^\ ]*\s?)*`)
var str = `yt nw5Mc5bpq-A`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}