# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<numberExpression>(?<numberDice>[0-9]+)(?<gaussExpression>[oO]?(?<gaussDices>[0-9])+(?<gaussModifier>[\+\-])?)?)?[dD](?<faces>[0-9]+)(?<exploding>[¡!]{0,2})(?<modifierExpression>[\+\-](?<modifierValue>[0-9]+))?(?<thresholdExp>:(?<thresholdValue>[0-9]+))?"
test_str = ("Common dice:\n"
"1d2 (coin flip)\n"
"2d4\n"
"3d6\n"
"4d8\n"
"5d10\n"
"6d12\n"
"7d20\n"
"8d30\n"
"9d100\n\n"
"Gauss notation:\n"
"1o3d10 Basic notation\n"
"1o3+d10 Gauss with gauss-modifier\n"
"1o3-d10 Gauss with gauss-modifier\n"
"1o5d8 Gauss with other configurations\n\n"
"Exploding dice:\n"
"1d10! Exploding\n"
"1d10¡ Imploding\n"
"1d10!¡ Both, exploding and imploding\n"
"1d10¡! Another possible arrangement\n"
"1o3d10! Gauss exploding\n\n"
"Adding and substracting:\n"
"1d10+20\n"
"1d10-3 \n"
"1o3d10+3 Gauss with modifiers\n"
"1o3d10!-3 Gauss with exploding dice and modifiers\n\n"
"Threshold:\n"
"1d10:6\n"
"1d10+2:8 Modifier and threshold\n"
"1d10!+1:8 Exploding, modifier and threshold\n"
"1o3+d10!+3:8 Gauss with gauss-modifier, exploding option, modifier and threshold")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.